Apple Logic Pro

Topics

(1/4) > >>

[1] Logic Pro - technical specifications from Apple.com

[2] Logic Pro 8 Requires 10.4.9+, released september 2007

[3] logic 7.2.3 update (Sept 2006) support intel cpu on mac os x tiger

[4] Logic Pro X 10.5.1 Trial requires Mac OSX 10.14+ and 72GB for full install!

[5] Logic 9 (July 2009) Requirements (Snow Leopard - Mavericks)

[6] apples emagic support area

[7] article on Logic Audio Platinum 6.1 (Dec 2003)

[8] Logic 8 Pro (Sep 2007) Requirements (tiger or leopard)

[9] download logic studio 8 + logic express 8 (only for Macintosh PPC/Intel)

Navigation

[0] Up one level

[#] Next page

Go to full version