Author Topic: Spectrasonics Omnisphere 2 (aug 2015) requiers win7 + 10.8+!!!  (Read 1796 times)


Offline Project5er

  • Newbie
  • Posts: 21
  • Older Code, Cleaner Code
Re: Spectrasonics Omnisphere 2 (aug 2015) requiers win7 + 10.8+!!!
« Reply #1 on: December 04, 2015, 07:50:59 PM »
Holy Crap!...Well, this is just bloated Atmosphere with a few extra features. I use Atmosphere & Trilogy & that was about their pinnacle. No matter what these are all 'closed in VSTi'. You cannot import anything of your own, you can only change settings of supplied presets & save that or buy expansions. It should be called propellerhead omnisphere.

Offline chrisNova777

  • Administrator
  • Hero Member
  • Posts: 8615
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Re: Spectrasonics Omnisphere 2 (aug 2015) requiers win7 + 10.8+!!!
« Reply #2 on: December 04, 2015, 11:49:32 PM »
omnisphere 2 allows u to create instruments out of any recorded audio. watch the video!
honestly.. omnisphere is a great product. atmosphere was the first step.. this is the same thing,
but taken further.. its a great product by a great guy !