Operating Systems > Windows Vista (Jan 2007)

firefox will no longer support Vista or XP as of April 2017

(1/1)

chrisNova777:
From Firefox 53 planned for April 2017, Windows XP/Vista/Server 2008 are no longer supported
https://www.mozilla.org/en-US/firefox/50.1.0/system-requirements/

all firefox versions are available here:
https://ftp.mozilla.org/pub/firefox/releases/

https://en.wikipedia.org/wiki/Comparison_of_web_browsers

Navigation

[0] Message Index

Go to full version