Author Topic: windows 95 midi bug - interface error MSGSRV32  (Read 1041 times)

0 Members and 1 Guest are viewing this topic.

Online chrisNova777

  • Administrator
  • Posts: 8392
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
windows 95 midi bug - interface error MSGSRV32
« on: September 21, 2017, 08:59:11 PM »
https://www.sweetwater.com/sweetcare/articles/motu-issue-windows-95-interface-install/

Quote
MOTU Issue: Windows 95 interface install
Article #26082 Updated on Apr 27, 2007 at 12:00 AM
It is important to first confirm that the communication mode of your LPT port is set to EPP. This setting is usually established in the BIOS or CMOS of your system. You will also need to check what IRQ the LPT port is set for. Usually LPT:1 is set to IRQ 7. If you are using Windows 95, you can check what other device may be using the same IRQ by going to the System Control Panel, click the Device Manager tab, and double-click the Computer at the top of the list. Make sure that there isn’t another device set to use IRQ 7.

If you are receiving an error message that refers to MSGRV32, you are experiencing the Windows 95 MIDI bug. If there are more than 11 MIDI ports active, Windows will crash. Microsoft is aware of this issue. The MIDI Express XT will load 9 MIDI ports. Therefore, if you have more that 2 other MIDI ports, you are over the limit. A Sound Blaster soundcard will usually load 3 MIDI ports. To overcome this, you will first need to remove the MIDI Express XT driver. If you are using a MIDI Timepiece AV, you do not need to perform the steps below, skip to the next section.

1) When the computer is booting up, hit the F8 key when “Starting Windows 95” displays
2) From the menu that appears, choose “Safe Mode”
3) Once Windows 95 has booted, open the Multimedia control Panel
4) Select the Advanced page
5) Click the “+” next to MIDI Devices and Instruments
6) Double-click on an MXP port, and select remove

Then restart Windows, it will boot as normal. Now disable the other ports (Sound Blaster):

1) Open the Multimedia Control Panel
2) Click on the Advanced page
3) Expand the list for MIDI Devices and Instruments
4) Highlight each of the devices one by one, and select properties.

There will be a box that allows you to disable the MIDI features for that device.

Once you restart, you will be able to re-install the XT driver. If you have the MTP/AV, you should be all set.