Author Topic: Cubase 9.5 requirements (2017)  (Read 497 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Administrator
  • Posts: 8403
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Cubase 9.5 requirements (2017)
« on: October 14, 2018, 03:15:42 PM »
https://support.focusrite.com/hc/en-gb/articles/360001346325-Cubase-9-5-System-Requirements-for-Windows-Mac-OSX

Cubase 9.5: System Requirements for Windows & Mac OSX

Quote
System requirements: Cubase Pro 9.5 & Cubase Artist 9.5

MAC: OSX 10.11 / Mac OSX 10.12 / Mac OSX 10.13

WINDOWS: 64-Bit Windows 7 / 8.x / 10

    64-bit Intel or AMD multi-core processor (Intel i5 or faster recommended)
    4 GB RAM (8 GB or more recommended)
    18 GB free HD space
    1366 x 768 display resolution (1920 x 1080 recommended)
    Graphics card with DirectX 10 and WDDM 1.1 support (Windows only)
    USB port for USB-eLicenser dongle (license management)
    OS-compatible audio hardware*
    An internet connection is required for activation, account setup and personal/product registration. Additional downloads may be required for the installation.

    *Note: This software version does not support 32-bit plug-ins.
    *ASIO compatible audio hardware recommended for low-latency performance.

Quote
Cubase Elements 9.5, Cubase AI 9.5 & Cubase LE 9.5

MAC: OSX 10.11 / Mac OSX 10.12 / Mac OSX 10.13

WINDOWS: 64-Bit Windows 7 / 8.x / 10

    64-bit Intel or AMD multi-core processor (Intel i5 or faster recommended)
    4 GB RAM (8 GB or more recommended)
    12 GB free HD space
    1366 x 768 display resolution (1920 x 1080 recommended)
    Graphics card with DirectX 10 and WDDM 1.1 support (Windows only)
    eLicenser (license management): Activation codes are registered in Steinberg user accounts
    OS-compatible audio hardware*
    An internet connection is required for activation, account setup and personal/product registration. Additional downloads may be required for the installation.

    *Note: This software version does not support 32-bit plug-ins.
    *ASIO compatible audio hardware recommended for low-latency performance.
« Last Edit: November 03, 2018, 11:42:10 PM by chrisNova777 »