Recent | Who | USB Audio | Firewire AudioPCI | ISA | ATARI ST | IBM/DOS | WIN/PC | MAC | Drums | Synths | Modules | Sequencers | Samplers | Tape | Mixers | 80s
SW Timeline | GFX | Artists | MIDI | VST | iOS | android | E-mu | Ensoniq | Akai "S" | MPCs | Roland "MC"Roland "S" | Roland "JV" | JV addons | DrumMachines | 90s
this website is intended to be a community effort, if you have any information to add to any of the posts, videos, pictures, links, please feel free to add this information to the website! to help make it a more usefull reference.

Author Topic: Run Cubase VST on Windows NT/2000  (Read 1569 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Administrator
  • Posts: 6801
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Run Cubase VST on Windows NT/2000
« on: December 19, 2014, 12:34:46 AM »
mirrored this info from http://sunlightd.tripod.com/Info/CubaseNT.htm
which contains annoying advertisements


Quote

Cubase VST on Windows NT/2000

Running Cubase VST on a Windows NT or 2000 machine is tricky at best. However, there are a couple of tricks to get you started.

Installation

By far the easiest way to install is to install using the original 3.5 CD or disks. If you bought your copy recently, and got a copy of 3.7, you will find the installer will choke on the fact that you're running NT. To fix this, you can do the following.

For this patch you will need:

  • A Cubase 3.7 full install CD.
  • About 100Mb of hard disk space.
  • The 3.7R1 patch (see below).

Copy the Cubase CD to a folder on your hard disk. You need the CD 'setup.exe', 'readme.txt', and folders 'DirectX 6', 'Documentation', 'License' and 'Read Me'.

On NT, copy the contents of the support/debug/i386 folder from the Windows NT 4 CD-ROM to the same folder. Patch the setup.exe file so that it thinks it is running on Windows 95 by opening a command prompt in this folder and typing

setwin95        setup.exe

On Windows 2000, you can use the program 'APCOMPAT.EXE' on your Windows 2000 disk.

Run the setup. You will get 2 boxes saying 'Cannot use the Unicode version of ATL.DLL on a Windows 95 system', one right at the start, one during install. Press OK both times (they can be safely ignored).

When Cubase is installed, restart.

You should now have a working system. I think these are the steps I took. There's some timing instability (it tends to 'jitter' every so often, on my system at any rate). I can remember some problems with ASIO, so if you do, you might want to try to get hold of 3.5 from Steinberg (you can then update to 3.7R1).

Note that under 3.7, lots of people have problems with Cubase not detecting their dongle. I fixed mine by updating to 3.7R1.

Patches

Upgrading to later versions under NT is difficult - until version 3.7R1, there were many problems. I recommend that you update directly to version 3.7R1.

You can get all the patches from Steinberg's FTP sites: ftp://ftp.steinberg.de/dist/product_updates/windows/cubase/ and ftp://ftp.steinberg.net/dist/product_updates/windows/cubase/. You can also get the 3.7R1 patch from various mirror sites.

See this page for more information about 3.6R2 and earlier patches.

3.7R1

3.7R1 will install directly. You can obtain it from:

ftp://ftp.steinberg-na.com/dist/product_updates/windows/cubase/v3701/patches/

ftp://ftp.steinberg.de/dist/product_updates/windows/cubase/v3701/patches/

ftp://ftp.steinberg.net/dist/product_updates/windows/cubase/v3701/patches/

ftp://cubase.net/dist/product_updates/windows/cubase/v3701/patches/

ftp://ftp.itsm.uni-stuttgart.de/pub/Steinberg/

http://www.uni-erlangen.de/~unrz32/files/

I recommend using the 'all versions' installer (PC_All_VST_37R1_Update.exe), but since this is rather large (nearly 20Mb), you may wish to use the file specific to your version.

3.6R2

  • Install cubase32.vxd into \winnt\system32.
  • Install VST 3.6R2 Update.
  • Install mros32.dll into \Program Files\Steinberg\Cubase VST.

The first step is necessary to allow the update to proceed (3.6R2 doesn't support Windows NT, so it is necessary to install one of the Win9x-only files that it is updating so that the update doesn't fail). cubase32.vxd is from the Win95 installation of VST 3.5 or 3.502.

The last step is a downgrade to version 3.553 of the MROS support. 3.553 does not rely on a 16-bit MROS driver when running under NT.

DirectX ASIO Driver

Version 3.7 and above of Cubase VST include an ASIO DirectX driver. However, when you try and use this driver under Windows 2000 (which has full DirectX support) you will find that it cannot detect the DirectX version correctly. I have patched the ASIODX.DLL file from 3.7R1 so that it will allow the use of DirectX under Win2k. Download the patch and unzip into your 'Program Files\Asio' directory.

« Last Edit: December 19, 2014, 12:36:53 AM by chrisNova777 »