Recent | Online | Vintage | Modern | Win | Mac  OS9 | DOS | Amiga | Atari ST | Graphics | Midi io | Sequencers | Roland "MC" | E-mu | Ensoniq | Akai MPCs | Samplers | Akai "S" | Roland "S"Synths | VST Samplers | VST Synths | Roland "JV" | Modules | Drums | Mixers | Timeline | HackintoshArtists | Graphics

Welcome to Oldschooldaw.com! (Online since 2014) if you are human, Register & Login to gain more access to all boards here; Some guest permissions have been limited to reduce traffic from bots and encourage registration, while other Guest permissions have been added such as guest posting of attachments and guest responses to threads!

Author Topic: best firefox browser version for snow leopard, lion + mtn lion 45.9.0 ESR  (Read 373 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Underground tech support agent
  • Administrator
  • Posts: 9649
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • View Profile
    • www.oldschooldaw.com | vintage audio production software + hardware info
http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/

Quote
https://support.mozilla.org/en-US/kb/firefox-osx - Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8

Firefox 45.9.0esr will be the most up to date version with security fixes that will run.

http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/ http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/

The Firefox 48.0.2 was released August 24, 2016 and is missing several security updates that the Firefox 45.9.0esr released on April 19, 2017 has.


Offline chrisNova777

  • Underground tech support agent
  • Administrator
  • Posts: 9649
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • View Profile
    • www.oldschooldaw.com | vintage audio production software + hardware info
snow leopard was the bomb!!!  8)  ;D
it really sucks that the big meanies of the internet can choose to simply not support an old os.
i was a developer i understand it sucks to make your code work on 10,0000 different platforms,
ie + netscape was bad enough back in the day (given me headache just remembering) but
i really miss using snow leopard it was just a really good experience and it sucks that internet giants choose to turn there back on supporting older machines

https://parrotgeek.com/fxlegacy.html
this page has a unofficial build of 52.9.1 which is the version that still supports mavericks, yosemite + el capitan (10.9 thru 10.11)
https://www.mozilla.org/en-US/firefox/52.0esr/releasenotes/
i havent tested it on snow leopard yet because the above version (45.9) was working so awesome, no errors, no certificate problems for the most part