Im on the look for opcode studio vision cd installer's - any version prior to 4.0! (i already have a copy of 4.0) if anyone has 3.5 or 2.08 and feels like uploading a copy to share with me, please send PM! thanks

Author Topic: firefox will no longer support Vista or XP as of April 2017  (Read 85 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Administrator
  • Hero Member
  • Posts: 4033
  • Karma: +17/-0
  • Gender: Male
  • "vintage midi sequencing and audio processing"
firefox will no longer support Vista or XP as of April 2017
« on: January 05, 2017, 12:16:30 AM »
From Firefox 53 planned for April 2017, Windows XP/Vista/Server 2008 are no longer supported
https://www.mozilla.org/en-US/firefox/50.1.0/system-requirements/

all firefox versions are available here:
https://ftp.mozilla.org/pub/firefox/releases/

https://en.wikipedia.org/wiki/Comparison_of_web_browsers