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Emagic Soft- und Hardware GmbH—
Software License Agreement
PLEASE READ THIS SOFTWARE LICENSE AGREEMENT (“LICENSE”) BEFORE USING THE SOFT-
WARE. BY USING THE SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS 
LICENSE. IF YOU ARE ACCESSING THE SOFTWARE ELECTRONICALLY, SIGNIFY YOUR AGREEMENT 
TO BE BOUND BY THE TERMS OF THIS LICENSE BY CLICKING THE “AGREE/ACCEPT” BUTTON. IF 
YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, RETURN THE EMAGIC SOFTWARE TO THE 
PLACE WHERE YOU OBTAINED IT FOR A REFUND OR, IF THE SOFTWARE WAS ACCESSED ELEC-
TRONICALLY, CLICK “DISAGREE/DECLINE”.

IMPORTANT NOTE: To the extent this software may be used to reproduce materials, it is 
licensed to you only for reproduction of materials you are authorized or legally permitted to 
reproduce. 

1. General.  The software, documentation and any fonts accompanying this License 
whether on disk, in read only memory, on any other media or in any other form (collectively 
the “EMAGIC Software”) are licensed, not sold, to you by Emagic Soft-und Hardware GmbH 
(“EMAGIC”) for use only under the terms of this License, and EMAGIC reserves all rights not 
expressly granted to you. The rights granted herein are limited to EMAGIC’s and its licensors’ 
intellectual property rights in the EMAGIC Software and do not include any other patents or 
intellectual property rights. You own the media on which the EMAGIC Software is recorded 
but EMAGIC and/or EMAGIC’s licensor(s) retain ownership of the EMAGIC Software itself. The 
terms of this License will govern any software upgrades provided by EMAGIC that replace 
and/or supplement the original EMAGIC Software product, unless such upgrade is accompa-
nied by a separate license in which case the terms of that license will govern. 

2. Permitted License Uses and Restrictions.  This License allows you to simultaneously 
install the EMAGIC Software on any number of computers which you or your organization 
owns or leases, however, only one copy of the EMAGIC Software may be in use at any given 
time. The EMAGIC Software may be used to reproduce materials so long as such use is lim-
ited to reproduction of non-copyrighted materials, materials in which you own the copy-
right, or materials you are authorized or legally permitted to reproduce You may make 
backup copies of the EMAGIC Software as reasonably necessary in machine-readable form; 
provided that each backup copy includes all copyright or other proprietary notices con-
tained on the original. Except as and only to the extent expressly permitted in this License 
or by applicable law, you may not copy, decompile, reverse engineer, disassemble, modify, 
or create derivative works of the EMAGIC Software or any part thereof. THE EMAGIC SOFT-
WARE IS NOT INTENDED FOR USE IN THE OPERATION OF NUCLEAR FACILITIES, AIRCRAFT NAVI-
GATION OR COMMUNICATION SYSTEMS, AIR TRAFFIC CONTROL SYSTEMS, LIFE SUPPORT 
MACHINES OR OTHER EQUIPMENT IN WHICH THE FAILURE OF THE EMAGIC SOFTWARE COULD 
LEAD TO DEATH, PERSONAL INJURY, OR SEVERE PHYSICAL OR ENVIRONMENTAL DAMAGE. 



         

Logic 6 add en.book  Page 4  Tuesday, March 25, 2003  2:50 AM
3. Transfer.  You may not rent, lease, lend or sublicense the EMAGIC Software. You may, how-
ever, make a one-time permanent transfer of all of your license rights to the EMAGIC Soft-
ware to another party, provided that: (a) the transfer must include all of the EMAGIC Soft-
ware, including all its component parts, original media, printed materials and this License; 
(b) you do not retain any copies of the EMAGIC Software, full or partial, including copies 
stored on a computer or other storage device; and (c) the party receiving the EMAGIC Soft-
ware reads and agrees to accept the terms and conditions of this License. 

NFR (Not for Resale) Copies: Notwithstanding other sections of this License, EMAGIC Soft-
ware labeled or otherwise provided to you on a promotional basis may only be used for dem-
onstration, testing and evaluation purposes and may not be resold or transferred.

4. Termination.  This License is effective until terminated. Your rights under this License will 
terminate automatically without notice from EMAGIC if you fail to comply with any term(s) 
of this License. Upon the termination of this License, you shall cease all use of the EMAGIC 
Software and destroy all copies, full or partial, of the EMAGIC Software.

5. Limited Warranty on Media.  EMAGIC warrants the media on which the EMAGIC Software 
is recorded and delivered by EMAGIC to be free from defects in materials and workmanship 
under normal use for a period of ninety (90) days from the date of original retail purchase. 
Your exclusive remedy under this Section shall be, at EMAGIC’s option, a refund of the pur-
chase price of the product containing the EMAGIC Software or replacement of the EMAGIC 
Software which is returned to EMAGIC or an EMAGIC authorized representative with a copy 
of the receipt. THIS LIMITED WARRANTY AND ANY IMPLIED WARRANTIES ON THE MEDIA 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, OF SATIS-
FACTORY QUALITY, AND OF FITNESS FOR A PARTICULAR PURPOSE, ARE LIMITED IN DURATION TO 
NINETY (90) DAYS FROM THE DATE OF ORIGINAL RETAIL PURCHASE. SOME JURISDICTIONS DO 
NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITA-
TION MAY NOT APPLY TO YOU. THE LIMITED WARRANTY SET FORTH HEREIN IS THE ONLY WAR-
RANTY MADE TO YOU AND IS PROVIDED IN LIEU OF ANY OTHER WARRANTIES (IF ANY) CREATED 
BY ANY DOCUMENTATION OR PACKAGING. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL 
RIGHTS, AND YOU MAY ALSO HAVE OTHER RIGHTS WHICH VARY BY JURISDICTION.

6. Disclaimer of Warranties.  YOU EXPRESSLY ACKNOWLEDGE AND AGREE THAT USE OF THE 
EMAGIC SOFTWARE IS AT YOUR SOLE RISK AND THAT THE ENTIRE RISK AS TO SATISFACTORY 
QUALITY, PERFORMANCE, ACCURACY AND EFFORT IS WITH YOU. EXCEPT FOR THE LIMITED WAR-
RANTY ON MEDIA SET FORTH ABOVE AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICA-
BLE LAW, THE EMAGIC SOFTWARE IS PROVIDED “AS IS”, WITH ALL FAULTS AND WITHOUT WAR-
RANTY OF ANY KIND, AND EMAGIC AND EMAGIC’S LICENSORS (COLLECTIVELY REFERRED TO AS 
“EMAGIC” FOR THE PURPOSES OF SECTIONS 6 AND 7) HEREBY DISCLAIM ALL WARRANTIES AND 
CONDITIONS WITH RESPECT TO THE EMAGIC SOFTWARE, EITHER EXPRESS, IMPLIED OR STATU-
TORY, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES AND/OR CONDITIONS OF 
MERCHANTABILITY, OF SATISFACTORY QUALITY, OF FITNESS FOR A PARTICULAR PURPOSE, OF 
ACCURACY, OF QUIET ENJOYMENT, AND NON-INFRINGEMENT OF THIRD PARTY RIGHTS. EMAGIC 
DOES NOT WARRANT AGAINST INTERFERENCE WITH YOUR ENJOYMENT OF THE EMAGIC SOFT-
WARE, THAT THE FUNCTIONS CONTAINED IN THE EMAGIC SOFTWARE WILL MEET YOUR 
REQUIREMENTS, THAT THE OPERATION OF THE EMAGIC SOFTWARE WILL BE UNINTERRUPTED 
OR ERROR-FREE, OR THAT DEFECTS IN THE EMAGIC SOFTWARE WILL BE CORRECTED. NO ORAL 
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OR WRITTEN INFORMATION OR ADVICE GIVEN BY EMAGIC OR AN EMAGIC AUTHORIZED REPRE-
SENTATIVE SHALL CREATE A WARRANTY. SHOULD THE EMAGIC SOFTWARE PROVE DEFECTIVE, 
YOU ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION. SOME 
JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES OR LIMITATIONS ON 
APPLICABLE STATUTORY RIGHTS OF A CONSUMER, SO THE ABOVE EXCLUSION AND LIMITATIONS 
MAY NOT APPLY TO YOU. 

7. Limitation of Liability.  TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT SHALL 
EMAGIC BE LIABLE FOR PERSONAL INJURY, OR ANY INCIDENTAL, SPECIAL, INDIRECT OR CONSE-
QUENTIAL DAMAGES WHATSOEVER, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
PROFITS, LOSS OF DATA, BUSINESS INTERRUPTION OR ANY OTHER COMMERCIAL DAMAGES OR 
LOSSES, ARISING OUT OF OR RELATED TO YOUR USE OR INABILITY TO USE THE EMAGIC SOFT-
WARE, HOWEVER CAUSED, REGARDLESS OF THE THEORY OF LIABILITY (CONTRACT, TORT OR 
OTHERWISE) AND EVEN IF EMAGIC HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OF LIABILITY FOR PERSONAL INJURY, OR 
OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION MAY NOT APPLY TO YOU. In 
no event shall EMAGIC’s total liability to you for all damages (other than as may be required 
by applicable law in cases involving personal injury) exceed the amount of fifty dollars 
($50.00). The foregoing limitations will apply even if the above stated remedy fails of its 
essential purpose.

8. Export Law Assurances.  You may not use or otherwise export or reexport the EMAGIC 
Software except as authorized by United States law and the laws of the jurisdiction in which 
the EMAGIC Software was obtained. In particular, but without limitation, the EMAGIC Soft-
ware may not be exported or re-exported (a) into (or to a national or resident of) any U.S. 
embargoed countries (currently Cuba, Iran, Iraq, Libya, North Korea, Sudan and Syria), or 
(b) to anyone on the U.S. Treasury Department’s list of Specially Designated Nationals or the 
U.S. Department of Commerce Denied Person’s List or Entity List. By using the EMAGIC Soft-
ware, you represent and warrant that you are not located in, under control of, or a national 
or resident of any such country or on any such list.

9. Government End Users.  The EMAGIC Software and related documentation are “Commer-
cial Items”, as that term is defined at 48 C.F.R. §2.101, consisting of “Commercial Computer 
Software” and “Commercial Computer Software Documentation”, as such terms are used in 
48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 
48 C.F.R. §227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Soft-
ware and Commercial Computer Software Documentation are being licensed to U.S. Govern-
ment end users (a) only as Commercial Items and (b) with only those rights as are granted 
to all other end users pursuant to the terms and conditions herein. Unpublished-rights 
reserved under the copyright laws of the United States.

10. Controlling Law and Severability.  This License will be governed by the laws of the Fed-
eral Republic of Germany. 
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11. Complete Agreement; Governing Language.  This License constitutes the entire agreement 
between the parties with respect to the use of the EMAGIC Software licensed hereunder and super-
sedes all prior or contemporaneous understandings regarding such subject matter. No amendment to 
or modification of this License will be binding unless in writing and signed by EMAGIC. Any translation 
of this License is done for local requirements and in the event of a dispute between the English and 
any non-English versions, the English version of this License shall govern.

12. MPEG-2 Notice.  To the extent that the EMAGIC Software contains MPEG-2 functionality, the follow-
ing provision applies: ANY USE OF THIS PRODUCT OTHER THAN CONSUMER PERSONAL USE IN ANY MAN-
NER THAT COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR PACKAGED 
MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE PATENTS IN THE MPEG-2 
PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM MPEG LA, L.L.C., 250 STEELE STREET, SUITE 
300, DENVER, COLORADO 80206.



 

Table of Contents

   

Ö

       

Logic 6 add en.book  Page 7  Tuesday, March 25, 2003  2:50 AM
1 General    9
1.1 New Way to Set the Dialog Language    9

2 Mixer    10
2.1 Channel EQ    10

2.1.1 Inserting a Channel EQ    12
2.1.2 Setting EQ Parameters    12

2.2 Tape Delay    16
2.3 Groups    17

2.3.1 Assigning a Channel to a Group    17
2.3.2 Group Settings    18
2.3.3 Group Automation    19
2.3.4 Temporarily Disable a Group (Clutch)    20
2.3.5 Group Handling on the Logic Control    20
2.3.6 Supported Control Surfaces    20

2.4 Automation Quick Access    21
2.4.1 Setting Up Automation Quick Access    21

2.5 New Options for Digital Mixdown/Bounce    22
2.5.1 Bouncing MP3 Format Audio Files    22
2.5.2 Bounce Mode    24

3 Arrange Window    26
3.1 Freeze    26

3.1.1 Concept    26
3.1.2 Application    27
3.1.3 How to Freeze a Track    28
3.1.4 Freeze Files    30

3.2 Arrange Channel Strip    31
3.3 Hide Tracks    31
3.4 Sample-accurate Waveform Display    32
3.5 The Marquee Tool    33
3.6 Time Stretching Regions    34
3.7 New Arrange Icons    35

3.7.1 User-definable Icons    35
3.7.2 Icon Color    36
7
Reference Addendum
Version 6



  

Table of Contents

          

Logic 6 add en.book  Page 8  Tuesday, March 25, 2003  2:50 AM
4 Editor Windows    37
4.1 Improved Time Machine in the Sample Editor    37
4.2 Chord Recognition in the Matrix Editor    38

5 Audio Standard Support    39
5.1 MP3 Support (Mac OS X only)    39

5.1.1 MP3 Import    39
5.1.2 MP3 Export    39

6 Video    42
6.1 DV Movie Playback via FireWire    42
6.2 Video Thumbnail Track    42

7 Project Manager    44
7.1 Project Manager Window    44

7.1.1 Short Description of the Main Functions and Modes    44
7.2 Scanning    47
7.3 Browse Mode    50
7.4 Edit menu    52

7.4.1 Renaming Files    54
7.5 Functions Menu    54
7.6 View Menu    65
7.7 Navigate    66
7.8 Find Mode    67

7.8.1 Find Mode Filter    70
7.9 Log File    71
7.10 Project Manager Preferences    71
7.11 Comments    73

7.11.1 Displaying and Editing Comments    73
8
Emagic
Logic Platinum



   

Ö

              

Logic 6 add en.book  Page 9  Tuesday, March 25, 2003  2:50 AM
1 General

1.1 New Way to Set the Dialog 
Language

The Mac OS X version of Logic 6 features a new, Mac OS X compliant, way 
to set the dialog language (the “Display” Preference that was previously 
used has been removed):

•  Select the Logic 6 application in the Finder.

•  Press Ci (to open the Information dialog).

•  Select/Flip open the “Languages” section.

•  Choose the preferred language, and uncheck all other languages.
9
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2 Mixer

2.1 Channel EQ
The Channel EQ of Logic 6 replaces the track EQ which you know from 
older versions of Logic. The new equalizer offers a couple of advantages:

•  improved, extremely high sound quality

•  eight (rather than four) bands

•  expanded range for gain and Q, and a higher frequency resolution 
(even when compared with the Fat EQ)

•  needs less space on the surface of mixer channels

•  better clarity (via thumbnails) for EQ curves

•  variable position in the signal flow (i. e. can also be placed between 
plug-ins)

•  integrated FFT analyzer (pre/post EQ)

•  large graphic display with complete, and intuitive, parameter editing

The integrated precision analyzer (based on Fast Fourier Transformation 
algorithms—FFT) shows the energy (amplitude) of all frequency compo-
nents of the signal. The central display of the Channel EQ fulfills multiple 
display functions: it shows both the curve of the FFT analyzer and the EQ 
curve. An identically scaled frequency axis is shown for both. This allows 
you to easily recognize unwanted frequencies in the analyzer curve, 
while using the EQ to edit them accordingly.

You can switch the analyzer pre or post EQ in order to compare the original 
signal with your edits. You can, of course, also judge the excellent quality 
of the Channel EQ with your ears. We are sure you will be as excited with 
the results as we are!
10
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Using the Channel EQ as the Default
In order to be backwards-compatible with songs created in Logic version 
5 or earlier, the old track EQ is still available. All songs that don’t make use 
of the old track EQ are automatically switched to use the new Channel EQ. 

If your existing Autoload song uses pre-set track EQs, you should modify 
it: Remove the track EQs from all channels. Open Options > Song Settings 
and switch to the Old Songs page. Deactivate the Use pre-Logic 6 track EQ 
checkbox and resave your Autoload song (i. e. replace it). You can now use 
the Channel EQ in all new songs created with Logic 6.

� Please note that the track EQs of older songs are lost by activating 
this option. If you don’t want this to occur, you can use the Channel EQ 
of Logic 6 as a plug-in in older songs. Doing so will, however, be at the 
expense of the Thumbnail view and editing via the EQ page of the 
Logic Control.
11
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� Please note that the Channel EQ has four bands in the Audio version of 
Logic and eight bands in the Gold and Platinum versions. If songs with 
an 8-band EQ from those versions are opened in the Audio version, 
the settings for the additional bands are ignored, but preserved. 
Hence, after being edited in the Audio version, the songs can be 
reopened in the Gold and Platinum versions without any loss of infor-
mation.

2.1.1 Inserting a Channel EQ
The Channel EQ is inserted into the first available insert slot by double-
clicking the EQ area on the upper portion of mixer channel strips. This area 
will change to a thumbnail view of the Channel EQ display. The thumbnails 
provide an overview of the EQ settings used in each individual channel.

O-double-clicking will insert the EQ as the first plug-in and move all 
existing plug-ins of this channel one slot down (and redirecting their 
automation data accordingly, if necessary).

Alternatively, you can insert the Channel EQ in any desired slot as per 
other plug-ins. You’ll find it in the EQ section of the plug-in list. This is the 
only way to insert multiple Channel EQs. (Remember that only the first 
Channel EQ can be displayed as a thumbnail).

2.1.2 Setting EQ Parameters
The Band Type buttons above the display switch individual bands on or 
off.

You can set/adjust the band parameters either directly in the central EQ 
display, or in the parameter area below it. As you move the mouse hori-
zontally over the display, pivot marks for individual bands appear on the 
frequency axis, while the parameter area of the same band is highlighted. 
The following possibilities are available for changing the parameters of a 
band:
12
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•  Move the mouse horizontally over the display until the desired band 
is highlighted. Now click-hold the mouse button on the display back-
ground (not directly on a pivot point): vertical mouse movements 
change the Gain, horizontal movements change the Frequency of this 
band.

•  Click-hold directly on the (illuminated) pivot point of the desired 
band: vertical movements (up/down) change the Q value. The direc-
tion required to increase or decrease the Q value depends on whether 
you are above or below the zero line (this ensures that “up” increases, 
and “down” decreases the volume in this band—you will find this intu-
itively “correct”). Again, horizontal movements (left/right) change the 
Frequency of the band.

•  Click-hold on the desired parameter in the parameter area below the 
graphic display (Frequency, Gain/Slope or Q): Moving up increases, 
and down decreases, the value. In order to prevent accidental 
changes, this is the only way to change the Slope value of the high 
and lowpass filters (bands 1 & 8).

As long as your mouse arrow is in the access area of a band, its individual 
curve will be graphically inserted over the resulting curve of the entire 
equalizer.

� You can also edit Channel EQs via the Logic Control—by pushing the 
EQ button: this will open the first Channel EQ of the selected channel. 
If no Channel EQ is active/available, it will automatically be inserted in 
the first free insert slot.

Parameter Description
The maximum Gain per channel is ±24dB (exception: bands 1 & 8, see 
below), the Frequency ranges from 20Hz to 20.000Hz. The range of Q val-
ues depends on the band. The individual bands are defined as follows:

•  Band 1 is a highpass filter and band 8 is a lowpass filter. The Slope 
parameter can either be 6, 12, 18, 24, 36 or 48 dB/Oct(ave) and Q 
ranges from 0.10 to 100. Q doesn’t affect filters with a 6 dB/Oct slope. 
The maximum Q value without a resonant peak is 0.71.

•  Bands 2 and 7 are shelving equalizers. Their values for Q (steepness 
of their curves) range from 0.10 to 2.00.
13
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•  Bands 3—6 are so called “bell” or “peaking” equalizers. Q can range 
from 0.10 to 100. When set to 100, the equalizers only apply to a very 
narrow band, and can work in a similar fashion to notch filters.

� If Show EQs is activated in the parameter box of a channel, it is 
possible to see a thumbnail view of the Channel EQ displayed in the 
upper corner of a channel strip.

� You can reset all settings of the highlighted EQ band (except 
frequency) by A-clicking in the display area.

� You can reset individual parameters by A-clicking in the parameter 
area.

Master Gain
This fader adjusts the output level of a Channel EQ. This allows you to com-
pensate for level changes introduced by your EQ settings. Master Gain 
has a range of ±24 dB.

Analyzer On/Off
This button allows you to activate/deactivate the FFT analyzer.

� Please note that the FFT analyzer needs additional CPU resources. In 
fact, resource consumption increases significantly at higher resolu-
tions (see below)! We recommend that you disable the analyzer or 
close the Channel EQ window after setting the desired EQ parameters. 
This will free up CPU resources for other tasks.

Analyzer Mode
This flip menu determines the location of the analyzer, either in the Input 
(pre EQ) or Output (post EQ) of the equalizer section.

� The Analyzer pre EQ and Analyzer post EQ options allow you to visu-
ally compare the original and EQ’ed signals.
14
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Analyzer Resolution
This flip menu defines the resolution of the FFT analyzer—or more accu-
rately, the number of frequency bands. This determines not only the pre-
cision of measurements, but also the amount of CPU power needed. The 
options are as follows:

•  Resolution low (1024 points)

•  Resolution medium (2048 points)

•  Resolution high (4096 points)

� Higher resolutions are necessary whenever you need reliable results 
in the area of very low bass frequencies. (The bands derived from FFT 
analysis are divided in accordance with the frequency linear prin-
ciple—non-technically, this means that there are far more bands in 
the highest octave than in the lowest).

dB Warp and Analyzer Top
These two parameters allow you to change the vertical scale of the EQ and 
analyzer curves.

dB Warp allows you to increase the resolution of the EQ Gain parameter in 
the most interesting area around the zero line. Click-holding in the green 
dB scale on the left side of the graphic display, and moving the mouse up 
will increase it (down to decrease). The overall range is always ±30dB, 
but small values will be easier to recognize.

As soon as the Analyzer is activated, you can change the Analyzer Top 
parameter, which alters the scaling of the FFT analyzer, on the right side 
of the graphic display. The visible area represents a dynamic range of 60 
dB, but by click-holding and vertically dragging, you can adjust the maxi-
mum value between +20 dB and −40 dB. The Analyzer display is always 
dB-linear.
15
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2.2 Tape Delay
The additional parameters of the Tape Delay (previously reached via 
001011 button) have been integrated into its graphical user interface. As 
a result, the functionality of these parameters have changed slightly, as 
indicated in the following text.

There is a new Sync button. When the Sync button is engaged, the delay 
is synchronized to the song tempo of Logic 6. In this mode, the plug-in 
uses the internal tempo of Logic Platinum to determine the delay time. 
The sole purpose of the Tempo box is to display the current bpm value. 
This is as per the use of the Tape Delay in the past. 

Disengage Sync if you would like to adjust the delay time independently 
of the song tempo (or change the song tempo without changing the delay 
time). In this mode, the bpm value or ms values can be altered freely by 
click-holding in the Tempo or Delay (time) parameter fields while dragging 
up or down with the mouse. Note that click-dragging on the left-hand side 
of Delay field will increment the ms values in large steps. Click-dragging 
on the right-hand portion of the field will increment the ms values in small 
steps. Delay time is adjustable between 0 and 1260 ms.

The Freeze parameter captures the current delay repeats, and sustains 
them until the Freeze parameter is released.
16
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The Tape Delay includes an LFO for delay time modulation. Use it to pro-
duce chorus-like effects—even with long delays. The LFO offers adjust-
able Speed and Depth controls.

Flutter simulates the tape speed irregularities of the tape transports 
found in analog tape delay machines, and is adjustable in Rate and Inten-
sity.

Smooth determines how quickly the “analog tape” can change its speed 
when switching between different note values. It also evens out the 
effect of LFO modulation and tape flutter. Pitch changes caused by the 
use of LFO modulation or Flutter will sound less pronounced when the 
Smooth value is increased.

2.3 Groups
Logic 6 introduces Groups. A Group allows you to combine multiple chan-
nel strips in order to link some of their properties, e. g. their volume faders 
and mute buttons. If, for example, multiple audio tracks (with individual 
choir voices) are assigned to one Group, changing the volume of one choir 
track changes the volumes of all choir tracks. Individual level relation-
ships—at the time the channels assigned to the Group—are retained. 

Groups can also link the selection of objects in the Arrange window, 
thereby linking all edit operations you perform on grouped tracks. 

Up to 32 Groups can be created. Each channel can be a member of multi-
ple Groups.

2.3.1 Assigning a Channel to a Group
There is a new Group display in the channel—above the automation mode 
display. Clicking on the Group display opens the Group flip menu where 
one of the 32 Groups can be chosen, turned “off”, or the “Group Settings 
…” dialog window launched.
17
Reference Addendum
Version 6



Mixer

Logic 6 add en.book  Page 18  Tuesday, March 25, 2003  2:50 AM
Overlapping Groups
One channel can belong to more than one group. To assign an additional 
group to a channel, press S while choosing a Group via the Group flip 
menu.

Fast Assignment
Groups can be quickly set and cleared by holding O when clicking on the 
Group display. The last Group setting—also overlapping groups—will be 
applied to the current channel, without opening the flip menu.

2.3.2 Group Settings
The Group flip menu (of the Group display) also allows you to open the 
“Group Settings …”. In the group setting dialog, the following options can 
be set for each individual group:

Name
You can name each group.

Enable
A group can be completely disabled here.

Arrange Selection (Edit)
Selecting an arrange object on one member track of a group selects the 
same horizontal range of all member tracks. 

Arrange Track Zoom
Zooming an individual track of a group will zoom all members.

Arrange Track Hide
Hiding an individual track of a group will hide all members.

Arrange Track Record
Record enable/disable of an individual track of a group will record enable/
disable all members.

Automation Mode
Changing the automation mode of an individual track of a group will 
change the automation mode for all members.
18
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Instrument Color
Changing the color of one group member channel will assign this color to 
all group member channels.

Volume
Changing the volume fader of one group member channel will change the 
volume of all member channels—while maintaining the level relation-
ships between them. If possible, use a volume fader with a high initial set-
ting

Mute
The Mute status of all member channels is synchronized.

Pan
The panorama setting of all member channels is linked. As per volume, 
their initial relationships are maintained.

Surround

Send 1—8
You can link the Send levels individually for Sends 1—8. Different initial 
levels will be maintained.

2.3.3 Group Automation
For mix automation, any Group member can act as a “master” for an auto-
mated parameter such as “Volume”. When an automation parameter 
value is written, the corresponding value of all other Group members is 
also written, depending on their Automation mode (e. g. Touch or Latch). 
The data is written individually for each channel. As a result, you can dis-
able the Group later, without affecting the automation of any Group mem-
ber—and can obviously edit or change channels individually.
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2.3.4 Temporarily Disable a Group (Clutch)
It is possible to temporarily disable all Group parameter links—e. g. in 
order to change the volume of an individual channel, even if it is member 
of a Group with linked volumes. To do so, simply use the Toggle Group 
Clutch Key Command (default g). As long as the Clutch is active, all 
Group displays will change color—from yellow (normal) to blue (Clutch 
active, all Groups temporarily disabled).

2.3.5 Group Handling on the Logic Control
Click-holding the GROUP button allows you to use the SELECT buttons to 
assign the selected channels to the next free (new) group. You can use 
the BANK switches during this operation.

While in the Group mode (click and release the GROUP button), you can 
switch between Groups with I and M. The Group number (G1—G9, 10—
32) is displayed in the 7-segment ASSIGNMENT display; the first charac-
ters of the Group name are displayed in the SMPTE/BAR display.

The LC-Display shows the track names in the top line. The bottom line will 
indicate the Group properties of the selected Group. J and K switch to 
further pages of Group properties. The SELECT keys display/edit the 
assignment of their channel to the currently selected Group.

TRACK+GROUP activates a Track Multi Channel View mode, which allows 
you to assign each channel to any Group (or turn it “off”) via each chan-
nel’s V-Pot. Alternatively, you can enter this mode by pressing TRACK and 
then J or K until you reach the “Group” page.

2.3.6 Supported Control Surfaces
Logic supports various Control Surfaces besides the Logic Control. More 
information about Control Surfaces can be found in the folder “Control Sur-
faces Info” in the section “Service” of your Emagic Software CD. Here‘s an 
overview over the supported devices.

•  CM Labs Motormix

•  Emagic Logic Control, Logic Control XT

•  Mackie HUI, Baby HUI, Digital 8 Bus (software version 5)
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•  Radikal Technologies SAC-2K, SAC 2.2

•  Roland SI-24

•  Tascam US-224, US-428

•  Yamaha 01V96, 02R96, DM1000, DM2000

•  all other HUI-compatible devices

2.4 Automation Quick Access
This new feature makes Track Automation extremely fast and simple if 
you only have one hardware MIDI controller available (e. g. one fader on 
your MIDI keyboard or even just the Modulation wheel). You can use this 
single hardware controller to access the currently visible Automation 
parameter of the selected Track in the Arrange window.

2.4.1 Setting Up Automation Quick Access
Open the Automation Settings dialog: Options > Track Automation > Track 
Automation Settings…

There is a new section labeled: Automation Quick Access which can be 
enabled or disabled via a checkbox. Once enabled, click the Learn Mes-
sage button below, and move the hardware controller that you’d like to 
use for Automation Quick Access. The other parameters shown here will 
immediately identify and indicate the type of control element you are 
using (even quite exotic formats are supported). Disable the Learn Mes-
sage button, by clicking on it a second time, or close the Automation 
Quick Acess dialog.

Once done, you will have hardware control over any currently visible Auto-
mation parameter which is set in the current Arrange track.

Enable/Disable Automation Quick Access
In case you are using the Modulation Wheel for Automation Quick Access 
(AQA), you might want to switch between using it for AQA and “normal” 
Modulation Wheel duties—as MIDI controller #1.

This can be done with the global Toggle Automation Quick Access Key 
Command. 
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2.5 New Options for Digital Mixdown/
Bounce

The Bounce function allows you to write the signal of an Output object as 
an audio file, which would otherwise simply be played live. You can initiate 
the Bounce process(es) by clicking the “BNCE” button on the Output 
object channel that you would like to bounce.

The bounce dialog of Logic 6 has been restructured, and offers a couple of 
new options…

2.5.1 Bouncing MP3 Format Audio Files
Logic 6 for Mac OS X now allows the bouncing of MP3 (or by its correct 
name: MPEG-2-Layer-3) format files. This well-known data reduction for-
mat for digital audio signals was developed by the Fraunhofer Institute, 
and allows high compression rates while maintaining quite good audio 
quality (depending on the compression rate). MP3 is the current stan-
dard for audio file exchange via the Internet.

� Due to the fact that encoding an MP3 file equates to a loss of audio 
quality, you should not use MP3 files during a production if you have 
access to the same audio data in linear formats such as: AIFF, WAV or 
SDII.

If you set the File Format flip menu in the bounce dialog to MP3, you will 
see all available options for the encoder (which translates the PCM linear 
format into compressed MP3 files).
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� You can change the default settings for the encoding engine via the 
Preferences > MP3 Export menu.

For details on the individual MP3 encoding parameters see the MP3 
Export Settings section, on page 40 of this addendum.
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2.5.2 Bounce Mode
The new Bounce dialog option Bounce Mode is available in Logic 6 for Mac 
OS X and Mac OS 9.

In older versions of Logic, bounces were always performed in real-time. 
The new Bounce Mode parameter allows you choose between two 
options:

•  Realtime: Creates the bounce file in real-time, as in older versions. 
Use it whenever you wish to bounce audio and audio instrument 
tracks plus external MIDI sound sources that are routed into the Logic 
Mixer via (Live) Input objects.

•  Offline: Accelerates the bounce process—depending on the complex-
ity of your arrangement and available CPU processing power. It also 
allows the bouncing of complex arrangements that would normally 
exceed the power of your CPU, if trying to play them in realtime. Offline 
bouncing, however, is limited to internal sources (audio tracks or 
audio instrument tracks). The MIDI tracks and Input Objects of Logic’s 
mixer are deactivated during offline bouncing.
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� Please note that the Offline Bounce Mode is only available to the 
Output objects of mixers that belong to native audio driver systems. 
DSP-based audio hardware (e. g. ProTools) can not make use of offline 
bouncing due to the nature of its stream-oriented technology.

� Other software applications, which are fed into your Logic Mixer via 
ReWire technology are available for offline bounce processes!

During an Offline Bounce, you can see the SPL moving through the song 
(usually much faster than real-time). A separate “bounce” progress bar is 
also shown.

Unlike online (realtime) bouncing, audio outputs will be muted during 
offline bouncing.
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3 Arrange Window

3.1 Freeze
Logic 6 introduces a completely new way to save almost 100% of the CPU 
power used for software instruments and effect plug-ins—namely, the 
innovative Freeze function. You can apply it, individually, to audio tracks 
or audio instrument tracks. 

3.1.1 Concept
Internally, Freeze performs individual offline bounce processes for each 
“frozen” track. All plug-ins of a track (including software instrument plug-
ins, if applicable, along with all related automation data) are rendered into 
a “freeze file”.

As long as a track is frozen—following the freeze process—this freeze file 
will play back in place of the original track (and its CPU-hungry plug-ins). 
The original track and plug-ins are temporarily deactivated, and use no 
CPU resources.

� Please note that the Freeze function always bounces all of a 
channel’s signals. If you are using more than one track that 
addresses the same audio or instrument channel, then all tracks of 
this channel will be frozen, and cannot be edited independently.

� Due to technical reasons, the Freeze function is not available for the 
tracks of DSP-based audio hardware systems (e. g. ProTools), tracks 
that use plug-ins which are calculated on DSP cards (Powercore, 
UAD-1, Pulsar etc.), or tracks that use external signal processing 
devices via the I/O plug-in. You can, however, “freeze” tracks that use 
Sends to Busses that have inserted DSP-based or I/O plug-ins.
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3.1.2 Application
In real-world situations, Freeze allows you to:

•  use additional plug-ins or software instruments in further audio or 
instrument tracks, which would normally not be possible as it would 
exceed the CPU processing limits of your computer.

•  play back songs created on computers with greater CPU power.

Freeze was made for very CPU-intensive processes, which are generally 
(from higher to lower demand) outlined as follows:

•  Software synthesizers with a complex voice architecture

•  Plug-ins with a complex structure (e. g. reverbs, filter banks or FFT-
based effects)

•  Software synthesizers with a simple voice architecture

•  Software sampler with active filter

•  Software sampler with deactivated filter

•  Plug-ins with a simple structure

As long as your computer is able to calculate all active processes in real-
time, it is not necessary to freeze a track.

Freeze is recommended whenever your system’s power runs short and 
one, or multiple, existing tracks with CPU-intensive instrument and/or 
effect plug-ins are in a final state, or at least seem to require no further 
changes for the meantime—i. e. “close to final”.

As long as a track is frozen, its CPU usage is reduced to that of a high res-
olution audio track, without any effect plug-ins inserted—regardless of 
the number, or processing demands, of the plug-ins that were used origi-
nally.
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3.1.3 How to Freeze a Track
It is extremely easy to freeze a track: simply activate the Freeze button—
i. e. the button that features a small ice crystal icon. If the Freeze buttons 
are not visible, activate the View > Track Freeze Switch menu option in the 
Arrange window.

The Freeze button of the “Audio 1” track

Logic will create freeze files after receiving the next “Play” command. This 
allows you to activate the Freeze buttons of multiple tracks, and render 
their freeze files in one go.

During the Freeze process, the SPL will follow the currently rendered posi-
tion. A floating progress bar window is also displayed.

� Freeze files are always rendered between the song start and end 
mark—it is recommended that you check the song end mark in the 
bar ruler before starting a Freeze process. Please note that the end 
mark should be adjusted to include feedback-dependent delay repeti-
tions or reverb tails. Empty areas (digital zero) at the end of freeze 
files will automatically be removed after the Freeze process.

� You can abort freeze processes by pressing C.—in this scenario, 
the portion of the frozen track(s) that has already been rendered will 
remain in the freeze file(s), and will be used for playback. Frozen 
tracks will remain silent beyond this point.

� The freeze process uses 100% of available CPU power. If, for example, 
a track uses 40% of the CPU, its freeze file will be created in 2.5 times 
the realtime speed. If the original tracks uses 100% of the CPU power, 
the freeze process will happen in (approx.) real-time—even if offline 
bouncing is used.
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Working with Frozen Tracks
Once a track has been frozen, you cannot edit any instrument or plug-in 
parameters (or related automation data). You can, however, still edit the:

•  effect send levels and destinations,

•  panorama and surround parameters,

•  volume, mute and solo

of frozen tracks—including their automation data.

Whenever you try to edit “forbidden” parameters of frozen tracks, (e. g. 
plug-in parameters that were rendered into the freeze file), Logic will dis-
play an error message.

Error message if you attempt to edit a frozen track

In this situation:

•  deactivate the Freeze button of the track,

•  This will delete the freeze file. 

� Please note that the track will now use the amount of CPU processing 
power that it originally required, if you enter “Play” mode.

•  perform your edits,

•  activate the Freeze button again, if required.

It is not possible to cut and re-arrange the freeze files in any way, nor is it 
possible to mix the freeze files with their originals on a single track—you 
can use one or the other, not both!

It is also not possible to record audio on frozen tracks. In fact, the Record 
button will be hidden while a track is frozen.
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3.1.4 Freeze Files
The temporary freeze files are saved in a folder named “Freeze Files” 
which is created in the root directory of your song (e. g. the project 
folder). Usually, you won’t need to access these freeze files directly.

Logic manages these freeze files for you automatically in the back-
ground: They are created during the Freeze process, will play back in 
place of the original tracks (as long as these tracks are frozen), and will 
be deleted as soon as the Freeze button of the corresponding track is 
deactivated.

In some cases, however, it might be handy to use freeze files directly: e. g. 
if you want to freeze all of your tracks, and use the freeze files for a remix 
in another studio (on DSP-based systems, for example).

For these situations, it is possible to adapt the bit depth of the freeze files 
to your needs: in Logic > Preferences > Audio you can change the Freeze 
File Format from the default 32 Bit (float) to 24 Bit or even 16 Bit. 

Please note that only the 32 Bit float setting will ensure that the audio 
quality of frozen tracks is identical to that of the original tracks. 

In many cases, the 24 Bit setting will have no audible impact—but will 
reduce the disk traffic, further minimizing CPU usage, and allowing you to 
access the freeze files as audio files.
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3.2 Arrange Channel Strip
In Logic 6, the Channel Strip of 
the currently selected Arrange 
track will appear in the parame-
ter area of the Arrange window, 
provided that there is sufficient 
space to display it. If there is not 
enough vertical room, click the 
upper left triangles in the 
Sequence Parameter and/or 
Instrument Parameter Boxes 
and/or hide the Toolbox (View > 
Toolbox). The Arrange Channel 
Strip allows you to access all of 
the mixer channel functions 
(volume, pan, sends, inserts, 
etc) directly from the Arrange 
window. Any adjustments you 
make to a track’s Arrange Chan-
nel Strip will be reflected in the 
corresponding Track Mixer and 
Environment Channel Strip as 
well.

3.3 Hide Tracks
If there are tracks in the Arrange that you do not need or want visible, 
Logic 6 introduces the Hide Tracks feature.

There is a new global “HideView” button at the top of the Arrange. This is 
the big “H” button to the right of the Link button. When you activate this 
button by clicking on it, the Hide (small “H”) buttons on each individual 
track become available
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You may now activate the individual Hide buttons on the desired tracks, 
and when you de-activate the global HideView button, all Arrange tracks 
with Hide activated will be invisible. When you wish to see the hidden 
tracks again, simply re-activate the HideView button.

There are a number of Key Commands that relate to the Hide Tracks fea-
ture. Even when the global HideView is deactivated, you can still Hide an 
individual track with View > Hide current track and select next track menu 
option or Key Command. Finally, there is a Key Command to Unhide all 
Tracks which will reset the Hide buttons of each track, making them all 
visible.

Note: hiding tracks does not affect their playback in any way. You can also 
link the Hide functions of all tracks belonging to a Group by selecting Hide 
in the Group Property Settings. Another thing to keep in mind is that there 
is no Key Command for Unhide selected Arrange Track because there is no 
way that you can select a hidden Arrange track—it is hidden, after all …

The color codes of the global Hide View button:

Gray—no tracks hidden.
Green—setup mode, all tracks with individual hide buttons visible.
Orange—one or more tracks are hidden!

3.4 Sample-accurate Waveform 
Display

The Arrange window now displays 
the actual waveform of an audio 
file, all the way down to single sam-
ple resolution at the highest zoom 
levels. The new Waveform vertical 
zoom Key Commands make this 
feature even more useful; for pre-
cise Arrange edit operations, and 
for operations on audio regions 
with low signal levels.
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3.5 The Marquee Tool
Logic 6 introduces a new tool to the Arrange window’s toolbox: 
the Tool, which looks like a crosshair. This tool can also be 
selected via the Set Marquee Tool Key Command. You can use 

the Marquee tool by click-holding within the Arrange window (on the 
Arrange window background, or directly on objects) to begin your selec-
tion. A shaded selection rectangle will appear onscreen as you move the 
mouse. You can drag the selection rectangle freely, allowing you to make 
selections—independent of existing part/object boundaries; when you 
release the mouse, only the area that falls inside the “marquee” is 
selected. In other words, you can use the Marquee tool to make selections 
within existing regions and sequences; your selection is completely 
determined by the selected “marquee” area.

Within the selected area, you can perform almost all regular Arrange edit 
options, including:

•  Delete (B or click with the eraser tool)

•  Move (drag selection or using a Nudge Key Command)

•  Copy (O-drag) using the Arrow tool

•  Cut/Copy (Cx, Cc)

•  Paste (at SPL, quantized to the nearest bar divisions)

•  Copy/Paste via pencil tool (quantized to current format value)

•  Cut at selection border (click inside the selection with the scissors 
tool)
33
Reference Addendum
Version 6



Arrange Window

X

X

X

Logic 6 add en.book  Page 34  Tuesday, March 25, 2003  2:50 AM
•  Mute (Key Command or tool; will also result in a cut at the selection 
borders)

•  Solo (Key Command or tool; will also result in a cut at the selection 
borders).

If your selected area falls between musically relevant values, the Mar-
quee tool’s selection rectangle will automatically “snap” to the nearest 
musically relevant position, in accordance with the settings of the new 
“SmartSnap” feature. This facility adjusts the snap resolution according to 
the current zoom setting. If you make your selection while holding C, the 
selection will snap to the finest resolution possible within the chosen 
zoom factor. By holding down S, the current Marquee selection can be 
altered from either the left or right side, as well as up or down.

The new Crop objects outside Marquee Selection Key Command removes 
all unselected areas from objects which are partly selected by the mar-
quee.

3.6 Time Stretching Regions
Logic 6 allows you to change the length of audio regions (without chang-
ing their pitch) directly in the Arrange window—via menu options or key 
commands.

Adjust Object Length to Locators
Functions > Object > Adjust Object Length to Locators stretches or com-
presses selected audio regions (or MIDI sequences) to fit between the 
current positions of the left and right locators. The object’s start point is 
not changed by this function—so don’t be overly concerned if the Loca-
tors are not precisely above the region or sequence.

Adjust object length to nearest bar
Functions > Object > Adjust object length to nearest bar adjusts the length 
of selected regions to the closest whole bar. This provides an ideal 
method for fitting previously trimmed drum loops into songs where small 
discrepancies between the loop and song tempo exist.
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� These two functions use the most recently selected Time Stretching 
Algorithm—set in the Time and Pitch Machine (Sample Editor > 
Factory > Time and Pitch Machine).

3.7 New Arrange Icons
Logic 6 introduces a new icon format, offering 
high resolution, scalable (from 128 × 128 pixels 
downwards), and user-definable icons. A few of 
the new icons are direct replacements for the 
older Logic icons, but most of the previous icons 
remain in the program to ensure backwards 
compatibility. If you vertically zoom a track with 
new icons sufficiently, you will see the large 
size icon in addition to the small icon at the top.

3.7.1 User-definable Icons
You can create your own icons for Arrange tracks. These Icons must be at 
the size of 128 × 128 pixels, and must be saved in the “portable network 
graphics” format, and must have an alpha channel for transparency. 
Please note that these files must be saved with the “.png” suffix. The file-
name must also start with a three-digit number. If this number is below 
325, the corresponding built-in Logic icon will be replaced by your new 
graphic (you can check the number of existing Logic icons by double-
clicking on them in the Instrument Parameter Box).

In OS 9, user icons must be located inside the Emagic Resources > Icons 
subfolder within your Logic application folder. 

In OS X there are two possible locations for user icons:

The ~/Library/Application Support/Emagic/EmagicResources/Icons 
folder can contain icons which are only valid for the particular user (~ is 
the user name).

If you save your icons in the root directory—/Library/Application Support/
Emagic/EmagicResources/Icons—the icons are valid for all users.
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If icons with identical numbers exist in both folders, the icons found in the 
user folder have priority.

3.7.2 Icon Color
The old, monochromatic icons used to adopt the color of their “parent” 
Audio Object or MIDI Instrument—which is also still used for newly 
recorded Regions/Sequences in the Arrange window.

The new high resolution Arrange Icons have their own color and, therefore, 
can no longer adopt the “parent” object color. To circumvent the overriding 
color of the new icons, Logic 6 incorporates a small color strip on the right-
hand edge of the Track List.

The View > Shadow for Instrument Icons option was removed.
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4 Editor Windows

4.1 Improved Time Machine in the 
Sample Editor

The Time Machine in Logic 6 features four additional algorithms for time 
and pitch modifications. Each of the new algorithms is specialized for cer-
tain types of audio material. All new algorithms deliver the highest preci-
sion possible, to avoid alterations to the length of the audio material.

You can still use the Time Machine as per usual: from within the Factory 
menu of the Sample Editor (see the main Logic manual for instructions).

Audio Type
This new parameter allows you choose between the old and the four new 
algorithms:

•  Version 5 algorithm
this is, obviously, the well-known algorithm of Logic 5 and earlier ver-
sions.
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•  Any material
This is the most universal algorithm which, theoretically, should be 
able to handle most kinds of material—it is the new “default” setting 
when using the Time Machine. The following algorithms can, however, 
deliver better results in cases where the material exactly matches the 
following criteria:

•  Monophonic
A specialized algorithm for monophonic material, e. g. an individual 
voice, brass or woodwind.

•  Pads
Use this algorithm on polyphonic material with harmonic content, e. g. 
choirs or string sections.

•  Beats
This algorithm perfectly maintains the timing of percussive material. It 
should be your first choice for all kinds of drum loops. It may also be 
useful on staccato, rhythmic piano or guitar parts—i. e. “comping”. 
Experiment with this, if you find that the default algorithm isn’t deliv-
ering the desired results.

4.2 Chord Recognition in the 
Matrix Editor

When selecting multiple notes in the Matrix editor, the information section 
in the upper left corner now displays the chord name of the note combina-
tion being played.
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5 Audio Standard 
Support

5.1 MP3 Support (Mac OS X only)
The Mac OS X version of Logic 6 offers full support for the importing and 
exporting of MP3 files:

5.1.1 MP3 Import
MP3 files may be imported into Logic using the same methods employed 
when adding AIFF, SDII, or WAV files: namely by S-clicking with the pencil 
tool in the Arrange, using the Audio > Add Audio File command, via the 
Audio File local menu of the Audio Window, or by dragging MP3 files from 
the Finder into the Audio Window or Arrange.

When you import MP3 files, Logic converts the MP3 file to an AIFF file, and 
it is the AIFF file that is used in Logic. Logic does this because many func-
tions, such as waveform display, sample accurate editing, and so on, 
would tax the CPU if Logic had to constantly decode and re-encode the 
MP3 files in realtime for each change. By converting the MP3s to AIFF on 
import, Logic ensures the most efficient use of resources.

5.1.2 MP3 Export
Logic can export MP3 files as well, using technology Apple licensed from 
the Fraunhofer Institute, the developers of the MP3 format. You can select 
MP3 as a file format for Bouncing, or by using the “Convert to MP3” com-
mand in the Audio File local menu of the Audio Window.
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Bouncing MP3 Files
“MP3” is now one of the options in the pull-down File Format menu of the 
Bounce dialog. When you select MP3 as your file format, the bounce 
options for Resolution, Stereo File Type, Surround Bounce and Dithering 
are replaced by the “MP3 Export Settings” listed below. You can choose to 
Bounce MP3 files in realtime, or offline.

Convert To MP3
MP3 files can also be created from individual audio files by using the 
“Convert To MP3” command of the Audio File local menu in the Audio Win-
dow. When you create an MP3 file via this command, the encoder uses the 
Global settings of the MP3 Export Preference dialog, found in the Logic 
menu.

MP3 Export Settings
Below are the MP3 Export settings found in the Logic > Preferences > 
MP3 Export menu, along with some usage tips.

Bit Rate (Mono/Stereo)
The bit rates are selectable between 8kbps and 320kbps, but default to 
80kbps mono, and 160kbps stereo. These rates offer acceptable quality 
and good file compression. If you can afford the extra file size, we recom-
mend 96kbps for mono, and 192kbps for stereo streams, as this provides 
better audio quality. You can, of course, choose even higher rates, but the 
quality improvement in bit rates above 96/192kbps is minimal.
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Quality
Keep this set to Highest whenever possible. Reducing the quality will 
speed up the conversion process, but at the expense of audio quality.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses “simple” passages more heavily 
than harmonically-rich passages, generally resulting in better quality 
MP3s. Unfortunately, not all MP3 players can accurately decode VBR-
encoded MP3s, which is why this option is turned off by default. If you 
determine that the listener/s of your MP3 can decode VBR-encoded 
MP3s, you can switch this option on.

Use Best Encoding
Again, like the Quality parameter, you will gain encoding speed at the 
price of audio quality if this option is unchecked. This should always be 
left on, unless conversion time is an issue.

Filter Frequencies Below 10Hz
When this option is checked, frequencies below 10Hz (which are usually 
not reproduced by speakers, and are not audible to human ears, at any 
rate…) will be removed, leaving slightly more data bandwidth for the fre-
quencies which we can hear, resulting in an improvement in perceived 
quality. Only uncheck this if you’re experimenting with subsonic test 
tones, or exporting MP3s for whales …

Stereo Mode
You can select joint stereo or normal stereo mode. Depending on the orig-
inal file, these settings may (or may not) offer any audible difference. 
Experiment with both settings to determine your preference.
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6 Video

6.1 DV Movie Playback via FireWire
If you use a FireWire DV device for displaying QuickTime video (or a 
FireWire device connected to monitors for video display) we’ve added a 
new feature just for you: you can now output the opened QuickTime movie 
video from your Logic song to a FireWire device.

� Important: for technical reasons, only QuickTime movies in DV format 
are supported.

You can easily activate this option by selecting FireWire as the “DV Out-
put” option in the Global Preferences menu (your FireWire DV device must 
be connected at the time). You can also access this preference by open-
ing your QuickTime movie as usual (via the Open Movie Key Command or 
the Options menu), and then holding the mouse button down in the movie 
window. This will launch the Quicktime options pop-up menu.

6.2 Video Thumbnail Track

There is a new track class in the Arrange: the “Video Thumbnail Track”, 
which displays the loaded Quicktime movie as thumbnails on an Arrange 
Track. You can select this track class from the hierarchal menu of track 
classes. The number of thumbnails you can see at any given time 
depends on the current zoom level. The frames are always left-aligned, 
with the exception of the final movie frame, which is right-aligned. What 
this means is that left border of every frame (but the final frame) repre-
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sents the correct song position for that frame. The final frame is right-
aligned to ensure that, regardless of zoom level, at least the first and last 
frames of a movie will be visible. No editing operations are possible on 
Video Thumbnail tracks.
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7 Project Manager

7.1 Project Manager Window
The Project Manager is launched via the Windows > Open Project Manager 
menu entry.

7.1.1 Short Description of the Main Functions 
and Modes

A Logic song can use many different files which are not part of the song 
itself, but can be found as a variety of file types stored on the computer’s 
disk drives. These are the audio files, the settings of the plug-ins and soft-
ware instruments, the samples and instruments of the EXS24 sampler—
and maybe even Quicktime movies. Any of these files can be requested 
by different songs. As an example, the settings for your reverberation 
plug-ins will often be requested by different songs.

The Project Manager is a new window which can be found in the Windows 
menu: Select Windows > Project Manager in order to open it. The Project 
Manager allows you to organize the following types of data on your disk 
drives:

•  Song files

•  EXS24 Instruments

•  Audio files (and sample files for the EXS24)

•  Quicktime Movies

•  Setting files for all plug-ins (including software instruments)

The Project Manager recognizes the dependencies and relationships 
between these files. It recognizes which songs point to which audio 
file(s), and recognizes which samples are played back by which EXS 
instrument. (EXS samples are audio files as well. Any audio file can serve 
as a sample for the EXS24, in fact.)
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� Please note that although a Logic song file saves all parameters of 
each inserted plug-in, the song does not point to independent setting 
files for each plug-in.

In order to collect all necessary information, the Project Manager must 
first scan all drives, or at least all folders, used for the abovementioned 
file types. Dependent on disk(s) size(s) and the number of files, this may 
take quite a while, but the process runs in the background, allowing you 
to continue working. The resulting database is global (not song depen-
dent), and is stored separately from Logic’s preferences, in a special 
Logic PMData folder, found in the Preferences folder.

These are the main benefits of the Project Manager:

•  With the Save as Project function, you can save a song with all associ-
ated files. This allows you to save all necessary files into a folder that 
can be burned to CD, enabling easy transport to another location. This 
avoids any missing EXS24 Instruments, audio files or samples which 
need to be searched for, or reconstructed, in the studio. 

•  Once the data has been evaluated by the Project Manager, you can 
safely delete projects while avoiding the deletion of any files required 
for the playback of other songs/projects. 

•  Beyond saving and deleting, moving and copying of all data required 
for a project is quick and easy.

You can switch between the four basic operating modes of the Project 
Manager—Browse, Find, Log and Scan Paths—via the flip menu in the 
upper left corner.

Browse
The Browse mode displays all file types, laid out in category folders on the 
left side of the interface. You can set and use bookmarks for any folders.

As soon as you choose a specific file type, you will see all matching files 
displayed on the right-hand side of the window. All relevant information 
for each file is also displayed, including: location (path) and two optional 
comment fields. Clicking on the triangle icon beside an audio file will dis-
play the waveform, and a listing of songs in which it is used. You can use 
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the monitoring feature (similar to that found in the audio window), or 
launch the Sample Editor by double-clicking on the waveform overview. 
Movie files can also be opened by double-clicking on them (linked to the 
current song). 

Click on the triangle beside song file names to view a list of audio files and 
EXS Instruments that are used in the song. You can read more about this 
in the Browse Mode section, on page 50.

Find Mode
This mode activates a powerful search engine that allows you to search 
for all kinds of files which fulfill specified criteria, such as: name, file type 
and size. Further Functions are available for audio files. It is possible to 
limit searches to up to five definable paths. All search criteria can be 
saved to personal “filters”, with individual names. More on this can be 
found in the Find Mode section, on page 67.

Log File
In this mode, a simple log of all actions previously performed in the 
Project Manager is displayed. See the Log File section, on page 71, for fur-
ther information.

File > Save as project...
This global command internally uses the Project Manager’s database. Use 
it to Save a Song with all, or specific data types (audio files, EXS instru-
ments, samples, movie files), into a new folder—i. e. the “Project Folder”. 
This is useful for backing up a production, transferring a song to another 
studio, or simply to organize your hard disk(s) more efficiently …

Use of this command will launch the “Consolidate Song Functions” dialog 
window, where you can enter a “Project Folder Name” and choose from 
several options (mainly regarding choices to copy, move or simply leave 
certain file types at their current location(s)).
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7.2 Scanning
Before you can make use of the Project Manager, you must first scan your 
disk(s). This process will retrieve all relevant information from all rele-
vant files: all audio files, all songs, all EXS instruments, all Settings (plug-
in/software instruments) and all Quicktime movies. 

Scan Paths
It is recommended that you define Scan Paths prior to the initial Scan. 
Select Scan Paths (not Find Mode, Log File or Browse) in the flip menu to 
the top left of the Project Manager window. Any drive or folder excluded 
here will not be scanned. Two buttons allow you to define paths which 
should never be scanned (Add exclude path...). Within these excluded 
paths, there may be specific sub-folders that you wish to scan, despite 
the folder that is higher in the hierarchy being excluded (Add include 
path...). If you define nothing, all local volumes will be scanned in their 
entirety. Dependent on the number and size of the drives, and the num-
ber of files contained on these volumes, this may take a while. In using 
Scan Paths, you can speed up the scan significantly. As an example, you 
can exclude folders that contain thousands of “business” files, that have 
nothing to do with your audio and music applications.

•  Use Add exclude path... to define hard disks and folders that are 
never used for media files, e. g. Library and System folders, or irrele-
vant volumes.

•  Define Add include path..., for the Logic folder (for global EXS Instru-
ments), your global sample library folder, and the folder or volume 
used for your projects and songs. This path will be scanned, even if 
inside an “excluded” folder or disk.

� Please note that you can include sub-folders of excluded folders, or 
exclude sub-folders of included folders. Put another way: sub-folders 
can have priority over folders higher in the architecture. This means, 
for example, that you can define the “Applications” folder as an 
excluded path, but define the “Logic” folder (inside the “Applications” 
folder) as an included path. In this case, the “Logic” sub-folder will be 
scanned while all other sub-folders inside the “Applications” folder will 
not be scanned.
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•  If you wish to remove a defined path, select it and click Remove Path.

Included paths will be displayed on the right-hand side of the Project Man-
ager window.

•  Included paths are indicated by a (+) icon that precedes the path 
name. 

•  Excluded paths are shown below, and are indicated by a (-) icon that 
precedes the path name.

Scan
Select Browse mode via the selector to the top-left of the Project Manager 
(not Find Mode, Log File or Scan Paths). If you don’t select a specific folder 
in the left half of the Project Manager window, the scan process will scan 
all disks—in accordance with the defined exclude and include paths, if 
any. If you can’t recall the location(s) that you may have previously saved 
any of these file types to, you should perform a “global” scan.

You can start the scan process with the Functions > Scan option. The scan 
process can take some time, depending on the amount of data, and num-
ber and size of your hard disk drives. During the scan process, you can 
continue working in Logic’s other windows.

When the scan is completed, a folder structure appears on the left side of 
the Project Manager window, if Browse mode is selected.

Following this initial scan, please select Functions > Save Project Manager 
data at once. This ensures that—barring unforeseen circumstances—
this time-consuming scan procedure will never need to be repeated. The 
Project Manager’s database is automatically saved every time you quit 
Logic. 

During the scan process, the Project Manager checks every filename suf-
fix (e. g. “.aif(f)” for audio files in the audio interchange file format) and 
the file type of every file on your disks. Every file that appears to be an 
audio, song, EXS-instrument, setting or Quicktime movie file will be ana-
lyzed for its relationship to other files. As an example: the “relationship” 
could be between a song file that points to an audio file used as a region 
within the song. This is the type of information the Project manager deals 
with, and that is stored in the Project Manager database.
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You can rescan at any time. As a tip, we recommend that you only scan 
specified folders, where you expect to find these files. This saves time. 
You can choose the desired folders directly in the browser, and select 
Functions > Scan, or, if the respective folder does not yet appear in the 
browser, select Functions > Scan folder. Or you can define appropriate 
include paths, see the Scan Paths section, on page 47.

Expanded Scan
Functions > Expanded Scan works much like the standard Scan, but 
there’s a difference. Expanded Scan analyzes absolutely every file, 
regardless of whether or not the file type or suffix matches one of the file 
types being searched for. This allows you to select any file, even if its suf-
fix has been changed manually with the operating system file utilities, or 
if the file type information is invalid. The expanded scan takes much 
longer to analyze a file. As such we only recommend the use of this func-
tion on folders where such files can be expected. The function is espe-
cially useful in cases where specific files you expected to find during the 
normal Scan don’t show up.

Scan folder...
Functions > Scan folder is identical to Scan, but with the standard Scan 
command, you only can scan folders that appear in the Project Manager 
Browser. What about new folders that the Project Manager hasn’t yet 
noticed? If you select Functions > Scan folder, a folder selection dialog 
box appears onscreen. 

Stop Scan Process
Functions > Stop Scan Process is self-explanatory. This function is espe-
cially useful if you accidentally start an expanded scan of your entire 
disk/system. You’d probably want to stop this. All data detected up until 
the point when the Stop Scan Process command is initiated will not be 
lost.
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7.3 Browse Mode
In order to follow the Functions described in the following paragraphs, 
please select Browse (not Find Mode, Log File or Scan Paths) in the selec-
tor at the top left of the Project Manager window. Use Functions > Scan 
folder, and select a folder that contains songs and audio files. If these file 
types are located on different drives, perform two folder scans in order to 
view the appropriate Project Manager data. You can also scan all of your 
drives completely, but this may take a while, depending on the number of 
files/disk(s). Deselect any current selection in the Browse menu, and 
select Functions > Scan to do so. During the scan, you can continue work-
ing in Logic.

You’ll find the hierarchical structure of the Browser self-explanatory. After 
a full scan, the top-most hierarchical entry—above all the disks—is 
“Media on Disk”. The next level of the hierarchy is for the various data 
types: 

•  Audio Files 

•  EXS 24 Instruments

•  Logic Plug-in Settings

•  Movie Files

•  Song Files

� Please keep in mind that audio files can be referenced by a Logic song 
and by an EXS24 instrument.

Sub-division of Audio Files
The audio files are sub-divided into:

•  AIFF files

•  Recycle Files

•  Sound Designer I Files

•  Sound Designer II Files

•  WAV Files

These are different audio data formats that Logic can read/use without 
conversion.
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Left and Right Parts of the Project Manager Window
Every item in the gray Browse section is a folder. This also includes the 
display of sub-folders (the right-most) in the hierarchy. The contents (the 
files) are always (and only) displayed on the right-hand (light yellow) 
side. Click on an item in the lowest level of the hierarchy (one of the right-
most items—with no triangular arrow): The files in the selected folder will 
appear on the right-hand side. To the left of each entry, you will see arrows 
that display more information about the file and its relationships to other 
files, when clicked. 

•  For audio files, the waveform is displayed, along with songs and 
EXS24 instruments that refer to this audio file. 

•  For songs and EXS24 Instruments, the audio files they refer to are dis-
played.

� If you are using the Logic 6 default key commands, you can use the 
cursor keys to navigate the Project Manager window (read more in the 
Navigate section, on page 66).

Meaning of the Colors
On the right-hand side of the Project Manager, the files and their respec-
tive information are displayed in different colors. 

•  Black: This is a resolved (valid) reference from within a song or an 
EXS instrument, to an audio file—which means there’s a known path 
that is working fine and is in good order.

•  Green is used for the name, information and location info for the audio 
file, if the triangular arrow is clicked.

•  Grey is the color of duplicates. Logic is intelligent when it comes to 
recognizing duplicates: Even if the names and info are different, Logic 
will analyze the files byte by byte. If the audio is identical and the 
length (duration) is identical, the Project Manager will recognize that 
the file is a duplicate.

•  Red is the color of unresolved References. This means that there’s no 
file of the respective name in the folder path that was saved with the 
song or EXS instrument. This is quite common with samples that you 
have copied from CD to hard disk via the operating system’s drag and 
drop functions. From now on, you should use Functions > Install 
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from… and you will never again encounter a red, unresolved refer-
ence (see the Install Files From... section, on page 56). To make your 
life even easier, the Project Manager features an intelligent function 
that automatically resolves red references (see the Find Unresolved 
Files for Selected section, on page 62).

7.4 Edit menu
Cut, Paste and Clear
When you copy, move or delete files from within the operating system (on 
the desktop), the Project Manager isn’t aware of these changes, and 
therefore can’t recognize the new locations of the files. As such, we rec-
ommend that you perform these operations with the Cut, Paste and Clear 
functions of the Project Manager Edit menu. This ensures that the Project 
Manager database is always up to date, regarding the location (and exist-
ence) of any relevant file(s).

� Note that it is possible to update the database at any time (see the 
Check For Modified Or Deleted Files section, on page 54).

Cut allows you to select files that shall be moved. Paste is used to define 
a destination folder for these “cut” files.

If you move (Cut and Paste) audio files, all songs and sampler instru-
ments referring to these files will automatically be updated to reflect the 
new file locations. 

The Clear function actually deletes the files from disk. 

� Caution! “Cleared” files will not only be removed from the Project 
Manager database, but will be moved to the Trash folder. Next time 
you empty the Trash, the files will be deleted and can not be recov-
ered!
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If you wish to define a new folder (which is not yet known by the Project 
Manager) as destination for the move or copy process, make use of the 
Functions > Move Selected or Copy Selected functions. (More information 
can be found in the Move Selected section, on page 64 and also in the 
Copy Selected section, on page 64).

Select All
Use this command to apply operations to all files that are visible in the 
right-hand side of the window. Note that this function does not select all 
files in all folders. Only the entire contents of the folder selected on the 
left-hand side of the Project Manager window will be selected.

Select Unused/ Unreferenced Audio Files
Edit > Select Unused Audio Files and Select Unreferenced Audio Files are 
functions that can be used to select particular audio files that are not cur-
rently in use. Most commonly, this function will be used when you wish 
to delete them, or place them in a folder where they can be stored for pos-
sible future use.

So what’s the difference between the selection of unused and unrefer-
enced files? 

This function looks for all song and EXS instrument files, and then checks 
if these songs or EXS instruments can/cannot find their related audio 
files. Select Unused Audio Files selects all audio files that are not refer-
enced by any song or EXS instrument. Put another way: These are 
“orphaned” files that have no “used by:” info when you click on the trian-
gular arrow alongside their names.

Select Unreferenced Audio Files is a little smarter. This function also 
selects the unused audio files, but goes one step further. It also checks 
for songs or EXS instruments that attempt to point to audio files with iden-
tical names. Their path reference might be wrong, but this could be re-
established by performing Functions > Find unresolved files for selected!

Edit > Select Unreferenced Audio Files will not select unreferenced files 
with “suspect” names—i. e. files of a suitable (used) name that “could” be 
in a song/belong to an EXS instrument, thus protecting them from being 
deleted accidentally (see the Find Unresolved Files for Selected section, 
on page 62).
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This type of disorganization is typically created by copying folders manu-
ally from a sampling CD ROM to the hard disk, via the operating system’s 
drag and drop facilities. From now on, you can avoid this from happening: 
Whenever you want to add folders from sampling CD ROMS or firewire 
hard disks, use Functions > Install files from… (from within the Project 
Manager). This will ensure that all references are up to date.

Find Duplicates for Selected
This is a smart function that finds and selects duplicated files. The files 
may even have totally different names or file types—but will nonetheless 
be recognized as duplicates, as long their length and content (audio data, 
comments etc.) is identical. The slightest difference in content means 
that a file won’t be regarded as a duplicate.

Delete Duplicates for Selected
The function name explains its use. The algorithm used for the detection 
of duplicates is as per that mentioned above.

7.4.1 Renaming Files
If you hold ç, and double-click on a file in the right half of the Project 
Manager window, you can enter a new name for the file. In doing so, the 
new name information will automatically be updated in the references of 
all other related files. You should never rename audio files on the desktop, 
as this will destroy all existing references. All file types can be renamed 
as desired.

7.5 Functions Menu
Check For Modified Or Deleted Files
This function is used to ensure that all scanned data is still present, and 
has not been changed. This process also runs automatically from time to 
time. This function is useful for updating the selected data in the Project 
Manager’s database, should you have deleted, moved or copied files using 
the operating system. Normally, this isn’t recommended, but in the real 
world, these situations sometimes occur. As an example, copying a num-
ber of songs and audio into a folder in order to burn the folder onto a CD 
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ROM, for backup purposes. After the burn procedure, you might want to 
move the original folder to the Trash. Through use of Check For Modified Or 
Deleted Files, you can ensure that the Project Manager doesn’t expect to 
find, or look for, the existence of this folder.

Thanks to the Project Manager database, it’s much more convenient to 
backup projects systematically: Use Logic’s File > Save as project… fea-
ture to backup songs, associated audio and settings data to a folder that 
can be copied to a CD ROM. This feature is, in fact, the major benefit of the 
Project Manager. If you always work systematically, you normally won’t 
need to use the Check For Modified Or Deleted Files option.

Clear Scanned Data
This function, as its name implies, clears the scanned Project Manager 
data. If you select nothing, the entire database will be cleared. This would 
normally not be desirable, but may be useful if you had totally reorga-
nized the contents of your disk. This may be the case if you’ve backed up 
all of your data to CD ROMs, following the production of an album, and 
have cleared all songs and audio files used for the album.

If you select a folder in the Project Manager Browser, the Project Manager 
data related to the contents of that folder will be cleared. This is useful if 
you wish to exclude a folder from being associated with any file. Also take 
a look at the Scan Paths section, on page 47.

Save Project Manager Data
This option allows you to save the Project Manager’s database manually, 
even though this occurs automatically whenever you quit Logic. For 
power users who never quit Logic, this is a good option for saving the 
database, especially after the completion of longer scan procedures.

� Remember that the Project Manager data is not saved with songs. The 
database is independent of song files as it is related to all files. 
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Install Files From...
This is the function to use when importing sampling CDs which contain 
both audio files and EXS instruments. It’s also appropriate for the impor-
tation of songs (with all related audio) from a CD ROM which has been 
burnt on another computer running Logic. The import function is not 
restricted to CD. It can be used for any media type, including FireWire 
disks, or any folder that’s accessible from your system.

•  Selecting Functions > Install files from… opens the following window:

•  Select the medium and folder you wish to install. This does not neces-
sarily have to be a sampling CD with EXS instruments. Importing 
songs and their related audio (and settings and Quicktime movies) 
works in the same way. 

•  Press Choose.

•  A similar window appears, allowing you to define the destination 
folder. The destination must, of course, be a hard disk—not the source 
CD ROM which can’t be written to:
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•  You may wish to create a new folder by clicking on the dedicated but-
ton. Either way, the following dialog will provide an opportunity to 
define the sub-folder that you wish to save the Project into. 

•  Press Choose and this dialog will appear:

❖ If you Check Don’t install duplicates, no files (audio, EXS instru-
ments or songs …) will be installed, where duplicates already exist 
on the destination disk. The algorithm is intelligent, but can take a 
while to analyze the data. It recognizes duplicates even if the file-
names are different, by analyzing each byte of the files. You should 
57
Reference Addendum
Version 6



Project Manager

Logic 6 add en.book  Page 58  Tuesday, March 25, 2003  2:50 AM
only use this function if you suspect that the audio files to be 
installed already exist on your destination disk.

❖ Only install needed files looks for the names of files which are 
missing, according to the Project Manager database, and only 
installs files with matching names. This is particularly useful for 
sampling CD ROMs that have been installed manually, but improp-
erly.

❖ Copy, Move or Leave Instruments to global folder relates to the 
global EXS Sampler Instruments folder, and only deals with EXS 
“Sampler Instrument” files (.EXS). It’s recommended that all EXS 
instruments only be placed in this “global” folder (“Sampler Instru-
ments” in the Logic application folder). For CD ROMs, copying and 
moving is identical, but this is not the case with exchangeable 
media such as FireWire disks. If you select Move, the originals (on 
the FireWire disk) will be deleted. If Leave is used, the EXS Instru-
ments will remain on the medium (FireWire disk), and only the 
audio files will be “installed”. 

❖ Subfolder Name allows you to create (and name) a new sub-folder 
for copied or moved EXS Instruments. If you delete all characters in 
the Subfolder Name entry, no sub-folder will be created, and the 
installation will be performed directly into the selected “destina-
tion” folder.

•  Pressing Enter (“OK”) will execute the installation. The current status 
of the data evaluation and copying process is displayed as a small 
progress bar window.

Consolidate Selected Songs
In these days of big, fast hard disk drives, it’s recommended that all files 
used by a song be stored in a single folder. Within that folder, a standard-
ized structure for every song is desirable.
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� Traditionally, many Logic users saved audio files and song files in 
different folders, partitions or disk drives. This approach was reason-
able in the “dark ages” of slow internal IDE and fast external SCSI 
disks, when only the latter offered good audio and video perfor-
mance. These were also the days when audio was viewed as an 
“extra” to mainly MIDI-based productions. These days, there’s no need 
to seperate the information across multiple drives. This, however, 
does not mean that it’s no longer useful to backup all of your data—
this is still a must!

Functions > Consolidate Selected Songs is a function that organizes all 
song-related files into a well-sorted, standardized file structure—which 
will hopefully be adopted as a convention by all Logic users for all 
projects. This is how it works:

•  Be sure to select Browse mode (not Find Mode, Log File or Scan 
Paths) in the panel to the top left of the Project Manager window. Navi-
gate to the folder that contains the song that you wish to consolidate. 
Remember that in the Browser, you’ll find it in the “Song files” sub-
folder!

•  Select the desired song in the right-hand side of the Project Manager 
window. If no song is selected, the Functions > Consolidate Selected 
Songs option will be grayed out.

•  Select Functions > Consolidate Selected Songs. A file selector will be 
displayed. Feel free to create a new folder, and/or select the desired 
folder for the project, then press Enter. The following dialog will provide 
you with the opportunity to define the sub-folder into which the 
project will be saved. A dialog, offering several options, will appear 
onscreen:
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❖ Create a sub-folder for the entire project by typing an appropriate 
name into the Project folder name field. If you don’t enter a name, 
no sub-folder will be created in the folder selected beforehand.

❖ The following functions allow you to determine the type of data 
you’d like to save into the destination folder. 
Please note that the approach is quite different if you wish to 
consolidate a project for transport to another studio location 
(burning a CD with everything on it), or whether you just want to 
reorganize the files on your disk. The Copy, Leave and Move func-
tions are self-explanatory: If you select Move, the original file will be 
deleted. 

❖ When you want to export projects to a folder which is destined for 
CD ROM burning, select Copy for all file types. It’s rare that the audio 
files used by the song should not be copied or moved to the new 
project.

❖ If just keeping order on your hard disk, select Leave for any EXS 
samples and sampler instruments that are not specific to the song 
(drums, strings, bass and so on …). When song-specific samples 
are being utilized, all the EXS24 data (Sampler instruments and 
samples) should be copied into the dedicated folder.

❖ Whether to copy or move the Quicktime movie depends on your 
video data structure, and whether or not the CD ROM has the 
capacity for all audio and video data.
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❖ For the Unused Audio, there are different options available. Unused 
Audio indicates audio files present in the song’s Audio window, 
which are not used as regions in the Arrange window. In practise, 
this might be vocal takes that weren’t used in your arrangement, 
but that are still present in the Audio window. The Unused Audio 
parameter determines how these files are handled. If you choose 
Like Used, they are handled like the used audio files, and will 
appear in the same folder. If you select Separate, a dedicated sub-
folder for the unused audio files will automatically be created. This 
allows the unused files to be easily identified, which is convenient 
when deciding on which files should be moved to the Trash. 
Choosing Separate for the Unused files is a good option when 
you’re unsure of whether or not these files may be used later. The 
other plus is that Logic won’t ask for missing files when the song is 
reopened—even if the files are not used in the arrangement. 
Consolidated song files “know” where these files are saved. If you 
select Leave, the files will be left where they are, which makes it 
easy to delete the old version of the song, along with all unused 
files.

❖ Include songs sharing files with this song is a smart function that 
automatically collects and collates all related song versions into a 
single dedicated project folder, along with all other versions that 
share the same audio data. You may want to uncheck this option in 
cases where an audio file is used in a variety of totally different 
song projects. The function is only relevant to audio files in the 
Audio window, not to the sample files used by the EXS24.

❖ Delete empty folders after moving. In cases where you decide to 
Move files, you may wish to automatically delete any empty folders 
that remain. You should leave this smart function checked, as long 
as you don’t intend to “refill” these original folders.

❖ Set Song’s audio recording path. If you’re not yet finished with all 
recording sessions for a song, it’s a good idea to allow the Consoli-
date function to set the song’s audio record path for you. Future 
recordings will automatically be placed in the “right” folder struc-
ture, if this option remains checked.
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❖ Execute the Consolidate process by pressing OK (or Enter). A small 
progress window is shown at the top left of the screen. Have a look 
at the new structure after consolidation!

Add Selected Files To Audio Window
Most Project Manager functions don’t relate to the song that is currently 
opened. This option is an exception: As the name implies, Functions > Add 
selected Files To Audio Window adds the audio files selected in the right 
half of the Project Manager to the Audio window of the currently opened 
song. From there, they can be dragged to the Arrange window as per any 
audio file. 

Find Used Files for Selected
The “selected” files of the following functions refer to songs or EXS instru-
ments. In other words, this functionality is only available if you have 
selected one or multiple song(s) or EXS24 instrument(s). 

� Remember that you must first select a file in the right half of the 
Project Manager window—or a folder on the left.

The Functions > Find Used Files for Selected option searches the audio 
files for a given song or EXS instrument, even if valid references already 
exist. On occasion, different files can have the same name, which can lead 
to incorrect resolutions of file relationships. By using Find Used Files for 
Selected, all files with the appropriate name(s) will be recovered, and you 
can select the desired one(s) manually in the dialog. 

Find Unresolved Files for Selected
In cases where a song or an EXS instrument cannot find their related files 
(unresolved file references), Functions > Find Unresolved Files for 
Selected forces the Project Manager to search for any file with the right 
names that are missed by the song or EXS instrument. These references 
can be easily identified by color (red—along with the triangular arrows 
that point to them). In cases where only one appropriate file name is 
found for an unresolved reference, the Project Manager will automatically 
choose that file. The referenced file will then be shown in blue. 
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•  This function is intelligent. If there’s more than one matching file 
name, and the found files are identical, Find Unresolved Files for 
Selected chooses the file with the folder path that best matches the 
song (or EXS instrument). If there are several matches of the file 
name, but the found files are not identical, a dialog will open, allowing 
you to select the desired file. The files are compared byte by byte in 
order to define whether or not they are identical.

•  In the example shown, Find Unresolved Files for Selected has found 
12 references, leaving two unresolved, which do not exist on the 
drives. These two files have been deleted with the desktop Trash func-
tion—which is not recommended, but happens in real life.

Move Used for Selected EXS-Instruments
This function is used forEXS instruments only. It allows you to move all 
audio files (samples) that an EXS instrument utilizes into another 
folder—and change the respective references in one pass.

•  Create Subfolders creates a dedicated subfolder.

•  Delete empty subfolders removes empty folders, which may be left 
after a move. Normally, it’s recommended that you leave this parame-
ter checked.

Set Comment 1 for Selected
For info on this option, please read the Comments section, on page 73.
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Set Comment 2 for Selected
For info on this option, please read the Comments section, on page 73.

Move Selected
This option allows files to be moved from folder to folder, with the Project 
Manager keeping track of how all the references of respective files 
change. This ensures that they will “find” each other, next time you open 
a song or load an EXS instrument. The function works much like the Copy 
and Paste functions in the Project Manager Edit menu. The difference is 
that Functions > Move Selected opens a folder selection dialog, allowing 
you to create new folders and to select folders that are not yet present in 
the Project Manager Browser.

Copy Selected
Same as above, but copies of the selected files remain in their old loca-
tion. Any references will be updated to the copy destination. If you wish to 
make copies without changing existing references, copy the files outside 
of Logic, with the operating system’s copy feature.

Start/Stop Preview
Audio files displayed on the right-hand side of the Project Manager win-
dow can be auditioned. The display of audio files in the Project Manager is 
much like that of the Audio window, except that you can see and audition 
any audio file (including all samples) on any disk, without first having to 
add it to your song. The Start/Stop Preview function starts playback of the 
selected file. Playback is stopped with the same command. Playback 
makes use of the audio channel (audio object) that has been selected in 
the Audio window. 

� It is recommended that you select a stereophonic channel (without 
plug-ins) in your autoload song, routed directly to one of the main 
outputs that you’re permanently monitoring.

� The Project Manager’s Start/Stop Preview is available as a key 
command! The Logic 6 default is the Space key.
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7.6 View Menu
Show Details for Selected
This function is used to enhance the display of audio files. You may have 
already noticed the triangular arrow which is used to open the waveform 
display and the green reference information (the display of the songs 
and EXS instruments pointing to the file). By clicking on the triangular 
arrow to the left of the audio file name, you switch on/off the display of 
the details (waveform and references). The View > Show Details for 
Selected option switches the arrow on/off for all selected audio files, 
simultaneously. 

� In order to speed up the “Creating Waveform Display” progress bars 
that might appear, double-click on one, and press Finish.

The green reference information is also available for EXS instrument files. 
In this case, it lists all songs which make use of the selected EXS instru-
ment.

You can also apply Show Details for Selected to folders (selected on the 
left side of the Project Manager window) if they only contain audio or EXS 
instrument files.

Hide Details for Selected
Having read the preceding paragraph, this is self-explanatory. This View 
function closes the detailed information (waveform and references) for 
the selected audio files, so that a greater number of file names can be 
seen simultaneously.

Sort...
Allows you to determine the criteria by which you would like the entries 
sorted: 

•  Date

•  Size

•  Name

•  Info

•  Location
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•  Comment 1 or 

•  Comment 2

The order can be changed via View > Sort > Up or Down, respectively.

� Sorting, by name, info, location or comment, is alphabetical.

� For comment, please read the Comments section, on page 73.

Show Comment 1
For details on this view option, please read the Comments section, on 
page 73.

Show Comment 2
For more on this view option, please read the Comments section, on page 
73.

7.7 Navigate
You will generally navigate the Browser with the cursor keys.

The Navigate menu allows accelerated navigation in the Browser through 
the use of bookmarks.

Bookmark Selected Folder
If you select a folder, no matter what its level in the hierarchy, and click 
Navigate > Bookmark Selected Folder, this folder will appear in the Navi-
gate menu from now on. You can easily access the sub-folders and files in 
it, by clicking the desired entry in the Navigate menu.

Current
Selecting a folder and clicking Navigate > Current Folder hides all other 
folders, providing more room for the display of sub-folders within the 
folder. This offers you a better overview of the folders and files you intend 
to work without the irritation of, say, video and settings folders that you 
don’t intend to work with at the moment.
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Up
This navigate function moves the Browser one folder higher in the hierar-
chy level, showing all other folders sharing the same location/at the same 
level as the currently selected top-most folder.

Top
This makes all folders visible and moves the browser to the top level of the 
hierarchy, allowing navigation to all files.

Back
By double-clicking a duplicate, a used file, or the song or EXS24 Instru-
ment, the respective folder will be browsed to. By selecting Navigate > 
Back, you can easily return to the folder that contains the file that was 
previously selected.

7.8 Find Mode
As a Logic user, you can easily collect, collate and create tens of thou-
sands of files on your disks, organized in dozens and dozens of folders. 
Even for the most methodical of musicians, it’s hard to maintain a flaw-
less overview of the location of every single file. That’s why the Project 
Manager features a smart find mode. Find Mode allows you to find any 
file, using any search criteria, instantaneously. The analysis process of 
the Project Manager database is so fast, you don’t even have to press an 
execute button. 

Another major benefit of the Find mode is that it’s a great tool for the 
selection of multiple files residing in multiple folders. If you select these 
(using Edit > Select all/Ca), you can apply any of the Project Manager’s 
functions to the files returned by the Find.

Contains:, Comment: and + Comment
If you don’t enter any text string in the Contains or Comment parameters, 
all files meeting the criteria defined by the switches will be displayed. This 
makes it possible to limit your search to short audio files or files with a 
specific sample rate, regardless of name, for example.
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•  Type in a text string in the Contains field and all file names that fea-
ture the text string in their name will be found (as long as they meet 
the other criteria below).

•  Type in a string of text in the Comment field and all files with com-
ments containing the text string will be found (as long as they meet 
the other criteria below). Whether the text string is in Comment 1 or 2 
doesn’t matter. The text string is not case-sensitive.

•  If you type in a text string in + Comment only files that contain the 
text string under Comment and the text string under + Comment in 
their comments will be displayed. Again, whether the text string is in 
Comment 1 or 2, nor the order of both text strings is relevant.

� Read more about the Comments feature in the Comments section, on 
page 73.

Type
The Project Manager can show different file types simultaneously or can 
exclude any file type. If you click Audio, as in the example below, more 
audio-specific criteria can be selected.
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Size
If you look for Settings, EXS24 Instruments, movie files or songs, only the 
size can be defined in order to exclude certain files. These file types are 
usually searched for by (part of) their names, or by comments. For audio 
files, however, the file size is a good search criteria in some cases—albeit 
normally, defining the minimum or maximum length is more convenient, 
if you’re specifically looking for short drum sample files, for example.

Audio Search Criteria
•  You can search for mono, stereo or both audio file types. At least one, 

or both, must be selected.

•  You can search for AIFF, Wave, SD (SD1 and SDII) or REX audio files. At 
least one of these buttons must be checked. Leave all checked if you 
don’t remember what file type the required file is stored as.

•  You can specify the sample rates of the files you’re looking for, thus 
excluding 22.05kHz, or 96kHz, for example. 0kHz Min sample Rate 
and 384kHz Max sample Rate are the values to choose, if you want to 
see all audio files.

•  Similarly, you can define the bit rate of the files to be searched. Again, 
select a minimum of 0 and a maximum of 32 Bit if you wish to see all 
files.

•  You can define the length of the files that you wish to find. If you’re 
only searching for drum samples (or similar short files), you can eas-
ily exclude all long recording takes, for example—or vice-versa. Please 
note: you have the choice of four time units, that are counted: Hours, 
Minutes, Seconds and Sample Words (1/44, 100th sec., depending on 
the sample rate). Only full values (without a comma or decimal point) 
can be typed into the number field.

•  You can restrict the search to audio files that are used (by a song or 
an EXS instrument).

Only Show Files In The Following Paths
You can restrict the search to specific folders. If you check nothing here, 
the entire database is searched for the file. If you click one of the 1—5 but-
tons, a folder selector box will be displayed, allowing you to define the 
desired path. 
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The restriction to the specified folder becomes active immediately, with 
no need to engage any further switches. The folder path is displayed. The 
X button allows the deletion of the folder search definition. If you wish to 
search another folder, click the 1 button (or the respective number) 
again. You can search up to five folder paths in parallel. This is more than 
sufficient as you can always decide to search higher folder hierarchy lev-
els and, of course, switch off the search restriction to the five folders.

7.8.1 Find Mode Filter
In the Project Manager’s Find Mode, an additional Filter menu allows you 
to program, and save, the settings of the Find Mode. These Find Mode set-
tings are called Filters. 

So, what does it bring to the party? 

To give you an example, you may sometimes happen to search for 24 Bit 
audio files in the AIFF format, that are mono and shorter than one second, 
at a sample rate of 44.1kHz. Why? Because you’re preparing a collection 
of samples for a new EXS instrument. You can store the Find Mode setting 
for this specific type of search as a “filter”. As another example, you may 
often search for songs which have a “playback version” comment. 

•  When all the parameters of the Find Mode are set to your liking, 
select Filter > Save Filter Definition as… 
Enter the filter’s name in the ensuing window.

� The programmable filters include the text string parameter settings 
Contains:, Comment: and + Comment: as well as the Only Show Files 
in the Following Paths: settings. 

� The filter definition appears in the Filter.
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•  If you want to delete or rename a filter definition, select the respec-
tive functions in the Filter menu.

7.9 Log File
The Log File mode is nothing but a simple list of the actions performed in 
the Project Manager, allowing you to reconstruct what you did. The Project 
Manager manages a multitude of files in parallel. Therefore, there’s no 
undo function. But if you, say, moved a file to the wrong location and 
didn’t quite remember where that was, here’s a way to retrace your steps.

� The Log file also is accessible for other applications that can display 
ASCII files—e. g. TextEdit. You can find the PM.log file in HOME > 
Library > Preferences > Logic > PMData.

7.10 Project Manager Preferences
Automatically load Project Manager Database upon 
Program Start
In the Logic > Preferences > Global Preferences, there are two prefer-
ences for the Project Manager. Automatically load Project Manager Data-
base upon Program Start simply defines when the database is loaded. As 
this takes a few seconds, you can launch Logic without reading the data-
base immediately, thus starting Logic a little faster. The database is 
loaded as soon as you open the Project Manager window for the first time. 
Engaging this parameter is simply a matter of taste, and of how often you 
use the Project Manager. It has no effect on Logic’s functionality—apart 
from the time taken for the database to be loaded.

Always check for deleted Files after loading Project 
Manager Database
Always check for deleted Files after loading Project Manager Database 
does exactly what the parameter name says. The check for files that have 
been deleted by dragging them to the Trash with the operating system 
shouldn’t be necessary, if you’re disciplined enough to only “trash” files 
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from within the Project Manager. If your working style isn’t quite so 
“proper”, you can ensure that the Project Manager doesn’t miss a thing by 
checking this option. Needless to say, this procedure always takes a little 
time. If you’re relatively disciplined, and only move things to the Trash 
from within the Project Manager, you can reassure yourself that nothing’s 
been lost by periodically checking for deleted files manually (Function > 
Check for modified or deleted files). If you can maintain this level of disci-
pline, then you can leave this preference unchecked, and save yourself 
some time.

For searching files use
The following search functions affected by the Select for searching files 
use preference only deal with a case that should never happen. The case 
in question involves files that aren’t in the location that’s been saved with 
the song or EXS instrument, when loading a song or EXS instrument. 
That’s what the Project Manager is for, to prevent this! 

In the real world, however, you may occasionally and inadvertently 
moves file on the desktop, without using the Project Manager’s copy and 
move functions (see the Move Used for Selected EXS-Instruments sec-
tion, on page 63).

When opening a song or EXS24 instrument, Logic expects its audio files to 
be found in the locations saved with the song or EXS file. Even in versions 
prior to 6, Logic didn’t just offer a file selector box, in cases where files 
couldn’t be found where they should reside. In such instances, Logic 
would automatically search for the appropriate files with the right names 
on all disks, in every folder. As you may already know, this procedure 
could take a little while, especially with complex EXS instruments. This 
behavior still is possible. 

Select for searching files use Search engine Only tells Logic to search for 
every file on all disks, when a song or EXS instrument is opened, and its 
respective audio files cannot be found. Thus, every possible matching file 
with the right name will be found, but the search process takes a rela-
tively long time depending on the number of files and number and size of 
disks to be searched. This search method was used by Logic 5 and earlier 
versions.
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Select for searching files use Project Manager Database Only instructs 
Logic to search for the file using the Project Manager’s “knowledge” about 
the location of every file. If you haven’t scanned the appropriate folders or 
haven’t performed Functions > Check for modified or deleted files since 
the problem was created, the search may fail. The benefit of this setting is 
that Select for searching files use Project Manager Database Only is fast. 
If a song or EXS instrument fails to find its files, you should rescan and 
Check for modified or deleted files.

Select for searching files use Project Manager Database and Search 
Engine instructs Logic to use both strategies for searching. The advan-
tage: Logic will not display an error message (while opening a song or EXS 
instrument) asking if the necessary audio files are on your disk at all. The 
disadvantage: you will not realize that an audio file is missing in the 
Project Manager’s Database.

7.11 Comments
A feature introduced by Logic 6 is the “Comments” fields for each file: Each 
song, EXS instrument, and each audio file can have two comments as a 
part of the file structure itself. There’s one exception: The setting files for 
plug-ins do not inherit comments in their file structure. The Project Man-
ager, however, also remembers comments for setting files. The Project 
Manager retains the comments that are part of every audio file, EXS 
instrument, song and video, as well as for the settings files (which don’t 
allow comments in their own file format). The Project Manager is the tool 
used to display and edit these comments.

7.11.1 Displaying and Editing Comments
In the Project Manager’s Browse or Find Mode, select View > Show Com-
ment 1 and Show comment 2. There are always two comments. Use them 
as you like. There’s no functional difference between them—in fact these 
comments have no function at all, despite reminding you of something. 
When displaying both comments, you may wish to enlarge the window a 
little, or to move the borders between the columns of the table. To do so, 
just grab and drag them. 
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Double-click on the Comment entry of the respective file, and a box will 
appear onscreen. Type the comment into the text box and press Enter 
when done.

Set Comment for Selected
You can simultaneously enter a text Comment for all selected files. A 
“comment text” window appears, allowing you to type in the information. 
There are separate functions for the first and second comment.

Write Comments to Files if Possible
The Project Manager allows two explanatory comments of your choice for 
all files. Select View > Show Comment 1 and Show Comment 2 respec-
tively, in order to display these comments. Often, it’s desirable to write 
comments for multiple files in one pass. This is what Functions > Set Com-
ment 1 for selected… (and Functions > Set Comment 2 for selected…) 
are designed to be used for.

The comments can become part of the files, and thus recoverable when-
ever you perform a new scan, even after you should have selected Func-
tions > Clear scanned data. But there is one exception to this rule: The 
comments cannot be written into setting files. With setting files, the com-
ments only reside in the Project Manager’s database (and would be lost, 
in cases where you cleared the scanned data). With all other file types (all 
audio, instruments, and songs) the comments become part of the Project 
Manager’s database along with the files themselves. 

In order to transfer comments which have been typed in the Project Man-
ager to the files themselves, use Edit > Write Comments to Files if possi-
ble. The process only applies for files that you have actually selected on 
the right-hand side of the window—or to all files inside the folder that you 
have selected on the left side.

Remove Existing Comments from Files
Having read the paragraph above, this function is self-explanatory. Again, 
the operation only applies to files that you have actually selected in the 
right half of the Project Manager window.
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