Editor: Alesis D4/DM5

This Galaxy Plus Editors module adds support for the Alesis D4 and DM5 drum modules. The D4 and DM5 each contain over 500 sampled drum and percussion sounds, which can be triggered by MIDI or with built-in trigger inputs (placed on acoustic drums or percussion instruments, or drum sounds recorded on tape). These Alesis drum modules can also convert external triggers to MIDI notes.

The Macintosh user interface allows many parameters to be displayed simultaneously and grouped into windows that make it easy to understand and access the D4/DM5’s capabilities.

This editor manual describes only features specific to the D4/DM5 Editor. See your Galaxy Plus Editors manual for information on:

- Installing Editor and Librarian modules;
- Loading/sending Bundles, Banks, and Patches;
- Using common editing features such as graphic envelopes, pop-up menus, and numericals.

You should also read the “device specific” online Help, which is available from the Apple Help menu when an Edit or Librarian Window is active.

This manual does not attempt to teach D4/DM5 programming and it does not discuss each parameter in detail. Often, the effect of one parameter depends on the settings of other parameters. If you alter a parameter and don’t hear any change in sound, examine how other parameters may affect the desired outcome. Refer to your Alesis manual to learn how various parameters interact and affect the overall sound.
TABLE OF CONTENTS

Ch 1: Instrument Setup ................................................................. 1
  D4 Configuration ........................................................................... 1
  ROM Versions Earlier Than 1.02 .................................................... 1
  DM5 Configuration ....................................................................... 2

Ch 2: D4/DM5 Bank Types ............................................................. 3

Ch 3: Editing Drum Sets ................................................................. 4
  Drum Set Edit Window ................................................................. 4
  Drum Set ......................................................................................... 5
  Copying Note Settings ................................................................... 6
  Trigger Notes ................................................................................. 7
  Root Note and Footswitch ............................................................ 7
  Special Menu Commands ............................................................. 8

Ch 4: Editing Trigger Setups ........................................................... 9
  Trigger Setup Edit Window ............................................................ 9

Ch 5: Editing Program Table and System Info ................................. 11
  Program Table Edit Window ......................................................... 11
  Editing System Information ......................................................... 12
  System Information Edit Window ............................................... 13
D4 CONFIGURATION

Before using the Alesis D4 with Galaxy or Galaxy Plus Editors make sure:

- The instrument’s MIDI input and output are connected to your MIDI interface; if using a multiport interface, connect both MIDI cables to the same port number.
- The MIDI channel matches the Device ID setting in your OMS Studio Setup.
- The unit’s THRU setting is off.

To set the MIDI channel and thru parameters from the D4’s front panel:

1. Press the MIDI button until “CHANNEL” and “THRU” are displayed.
2. Use the cursor keys to select the channel parameter; then set the channel to match the Device ID number in your OMS Studio Setup.
3. Use the cursor keys to select the thru parameter; then set it to “OFF.”

ROM VERSIONS EARLIER THAN 1.02

Early versions of the D4 ROMs contained some problems that affect the use of your D4 Editor. To find out which ROM version your D4 has, press the Drum Set button and then press and hold the left and right cursor buttons simultaneously.

ROM versions 1.0 and 1.01 had limitations on how fast MIDI System Exclusive (sysex) messages could be accepted. The Has 1.01 or Older ROMs command, available in the Load/Send menu when a Drum Set Bank or Edit Window is open, adjusts the rate at which sysex is transmitted to the D4. If your D4 contains a ROM version earlier than 1.02, enable (check) this menu item.

ROM versions earlier than 1.02 also use a different format for Trigger Setup data. Although the Editor is capable of dealing with all versions, the Librarian must handle them differently. If you are using a version earlier than 1.02, set up your Bundle as follows:
1. Click the D4 device name in an open Bundle and choose **Bundle>Banks in Device**.

   The following dialog appears.

   ![Include which D4 banks?](image)

   **Figure 1: Banks in Device Dialog**

2. Check the option for **Trigger Setup (<1.02)**.
3. Uncheck the option for **Trigger Setup (>=1.02)**.
4. Click **OK** to confirm your selections and close the dialog box.

   ☆ **IMPORTANT:** Make sure that only one Trigger Setup item is selected. If both check boxes are selected, Galaxy will put both Bank types into the Bundle, which could cause problems when loading or sending the Bundle.

### DM5 Configuration

Before using the Alesis DM5 with Galaxy or Galaxy Plus Editors make sure:

- The instrument’s MIDI input and output are connected to your MIDI interface; if using a multiport interface, connect both MIDI cables to the same port number.
- The MIDI channel matches the Device ID setting in your OMS Studio Setup.
- The unit’s THRU setting is off.

To set the MIDI **channel** and **thru** parameters from the DM5’s front panel:

1. Press the MIDI button until “CHANNEL” and “THRU” are displayed.
2. Use the parameter keys to select the **channel** parameter; then set the channel to match the Device ID number in your OMS Studio Setup.
3. Use the parameter keys to select the **thru** parameter; then set it to “OFF.”
To open a new Bundle for the Alesis D4 or DM5:

1. Make sure your Current OMS Studio Setup contains either an Alesis D4 or DM5, then launch Galaxy Plus Editors. When launching Galaxy for the first time, Librarian modules for devices contained in your OMS Studio Setup are automatically installed.

2. Choose File>New Bundle. A dialog box listing all installed Librarian modules appears.

3. Select the D4 or DM5 by clicking the device name. Its name will become highlighted to illustrate that it’s selected.

4. Click the OK button to place all D4/DM5 Bank types in a new “Untitled” Bundle. When opening or creating a Bundle, a Bundle menu becomes available; to retrieve all Banks from your instrument, choose Bundle>Get All Banks in Bundle.

**Bank Types**

Below is a brief description of each D4/DM5 Bank type:

1. **Drum Set**: Bank of 21 drum sets—each specifying a keyboard layout of drum sounds with settings for volume, tuning, pan, and routing.

2. **Trigger Setup**: Stores settings for triggering parameters for each of the 12 external trigger inputs.

   D4 users, must choose Bundle>Banks in Device to specify your ROM version (see ROM Versions Earlier Than 1.02, pg. 1).

3. **Prog Tbl**: Determines how the D4/DM5 responds to MIDI program changes.

4. **System Info**: Defines global MIDI settings, configures footswitch mode, and enables “note chase.”
To edit a Drum Set:


![Figure 3: Drum Set Bank](image)

2. Highlight a patch from the Drum Set Bank and click the **Edit** button. You can also double-click a Drum Set to edit it.

**DRUM SET EDIT WINDOW**

The Drum Set Edit Window assigns drum and percussion sounds to keys, along with settings for volume, tuning, pan, and routing. This window also assigns MIDI notes to each of the 12 external trigger inputs.

![Figure 4: Drum Set Edit Window](image)

The Drum Set Edit Window consists of three main edit blocks: **Drum Set**, **Trigger Notes**, and **Root Note/Footswitch**.
The **Drum Set** edit block is the heart of the D4/DM5 editor, where sounds are selected, mapped to notes, tuned, and routed.

<table>
<thead>
<tr>
<th>Note</th>
<th>Bank</th>
<th>Drum</th>
<th>Volume</th>
<th>Coarse</th>
<th>Fine</th>
<th>Panning</th>
<th>Output</th>
<th>Assign Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>2</td>
<td>13</td>
<td>98</td>
<td>88</td>
<td>0</td>
<td>££</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>C#1</td>
<td>5</td>
<td>5</td>
<td>98</td>
<td>99</td>
<td>0</td>
<td>££</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>D1</td>
<td>8</td>
<td>8</td>
<td>98</td>
<td>90</td>
<td>0</td>
<td>££</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>E1</td>
<td>9</td>
<td>9</td>
<td>98</td>
<td>98</td>
<td>0</td>
<td>££</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>F1</td>
<td>10</td>
<td>1</td>
<td>98</td>
<td>90</td>
<td>-4</td>
<td>0</td>
<td>0</td>
<td>££</td>
</tr>
<tr>
<td>F#1</td>
<td>1</td>
<td>2</td>
<td>98</td>
<td>90</td>
<td>-2</td>
<td>0</td>
<td>0</td>
<td>££</td>
</tr>
<tr>
<td>G1</td>
<td>2</td>
<td>3</td>
<td>98</td>
<td>95</td>
<td>0</td>
<td>0</td>
<td>2</td>
<td>££</td>
</tr>
<tr>
<td>G#1</td>
<td>3</td>
<td>4</td>
<td>98</td>
<td>95</td>
<td>0</td>
<td>0</td>
<td>2</td>
<td>££</td>
</tr>
<tr>
<td>A1</td>
<td>4</td>
<td>5</td>
<td>98</td>
<td>90</td>
<td>-2</td>
<td>0</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>A#1</td>
<td>5</td>
<td>6</td>
<td>98</td>
<td>95</td>
<td>0</td>
<td>0</td>
<td>££</td>
<td>££</td>
</tr>
<tr>
<td>B1</td>
<td>6</td>
<td>7</td>
<td>98</td>
<td>90</td>
<td>0</td>
<td>0</td>
<td>££</td>
<td>££</td>
</tr>
</tbody>
</table>

Figure 5: Drum Set Edit Block

1. **Note**: Indicates the MIDI note being assigned, starting at the **Drum Set Root Note** (see [Root Note and Footswitch, pg. 7](#)) and covering a 61-note range. Clicking a note name selects the entire line for copying or pasting.

2. **Keyboard**: The column to the right of the note names is a scrollable keyboard for auditioning sounds. Clicking any note on the keyboard triggers the corresponding sound.

   Clicking the up/down arrows, scrolls the display an octave at a time. Option-clicking an arrow, scrolls one note at a time. The velocity of the MIDI note played is set with the Mac KV setting in the MouseKeys Window.

3. **Bank**: Specifies a Drum Bank from which the Drum Sound for that note is chosen.

4. **Drum**: Assigns a Drum Sound, from the indicated Drum Bank, for that note.

5. **Volume**: Sets the Drum Sound’s volume.

6. **Coarse**: Tunes the Drum Sound in semitone steps within a range of +3/-4 steps.

7. **Fine**: Tunes the Drum Sound in cents within a range of +99/-99 cents.

8. **Panning**: Pans the Drum Sound to any of seven possible stereo locations. The Output setting determines between which two outputs the sound is panned.

9. **Output**: Routes the Drum Sound to either the Main or Aux outputs.

10. **Assign Group**: Specifies a trigger mode for the Drum Sound.
COPYING NOTE SETTINGS

Settings for a note can be copied to another note, or even to another Drum Set.

1. Click the note name in the left column to select the source note and its parameters.

<table>
<thead>
<tr>
<th>Drum Set</th>
<th>Note</th>
<th>Drum</th>
<th>Volume Coarse</th>
<th>Panning</th>
<th>Output</th>
<th>Assign. Grp</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>C1</td>
<td>Kick</td>
<td>88</td>
<td>0</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>C#1</td>
<td>Snare</td>
<td>13 DryStick</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D1</td>
<td>Snare</td>
<td>5 HeartHand</td>
<td>99</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D#1</td>
<td>Perc</td>
<td>87 808Clap</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>E1</td>
<td>Snare</td>
<td>69 Split</td>
<td>57</td>
<td>0</td>
<td>Main Multi</td>
</tr>
</tbody>
</table>

Figure 6: Source Note Selected

2. Choose Edit>Copy.

3. Click the destination note name to select it.

If you are pasting to a different Drum Set, first open the Edit Window for the desired Drum Set.

<table>
<thead>
<tr>
<th>Drum Set</th>
<th>Note</th>
<th>Drum</th>
<th>Volume Coarse</th>
<th>Panning</th>
<th>Output</th>
<th>Assign. Grp</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>C1</td>
<td>Kick</td>
<td>2 Producer</td>
<td>88</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>C#1</td>
<td>Snare</td>
<td>13 DryStick</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D1</td>
<td>Snare</td>
<td>5 HeartHand</td>
<td>99</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D#1</td>
<td>Perc</td>
<td>87 808Clap</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>E1</td>
<td>Snare</td>
<td>69 Split</td>
<td>57</td>
<td>0</td>
<td>Main Multi</td>
</tr>
</tbody>
</table>

Figure 7: Destination Note Selected


The new note’s parameters are then updated.

<table>
<thead>
<tr>
<th>Drum Set</th>
<th>Note</th>
<th>Drum</th>
<th>Volume Coarse</th>
<th>Panning</th>
<th>Output</th>
<th>Assign. Grp</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>C1</td>
<td>Kick</td>
<td>2 Producer</td>
<td>88</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>C#1</td>
<td>Snare</td>
<td>13 DryStick</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D1</td>
<td>Snare</td>
<td>5 HeartHand</td>
<td>99</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>D#1</td>
<td>Perc</td>
<td>87 808Clap</td>
<td>50</td>
<td>0</td>
<td>Main Multi</td>
</tr>
<tr>
<td></td>
<td>E1</td>
<td>Snare</td>
<td>69 Split</td>
<td>57</td>
<td>0</td>
<td>Main Multi</td>
</tr>
</tbody>
</table>

Figure 8: Note Pasted into Destination

COPYING PARAMETERS

Individual parameters can be copied to other notes, or Drum Sets, in similar fashion. Do this by clicking the individual source and destination fields instead of the note names. Additionally, multiple parameters can be copied by shift-clicking on source and destination fields.

Of course, these copy/pasting techniques may also be used in other Edit Windows.
**Trigger Notes**

In the *Trigger Notes* edit block, each of the D4/DM5’s external trigger inputs is mapped to a MIDI note. This mapping determines both which sound is triggered and which MIDI note is output.

<table>
<thead>
<tr>
<th>Trigger Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
</tbody>
</table>

Figure 9: Trigger Notes Edit Block

The left column shows the external trigger input numbers, to which the *Trigger Notes* column assigns MIDI notes.

**Root Note and Footswitch**

The third edit block of the Drum Set Editor, edits *Root Note* and *Footswitch* settings.

<table>
<thead>
<tr>
<th>Drum Set Root Note</th>
<th>FootSwitch Closing</th>
<th>FootSwitch Held</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>G#1</td>
<td>F#1</td>
</tr>
</tbody>
</table>

Figure 10: Drum Set General Edit Block

- **Drum Set Root Note**: Sets the lowest MIDI note to be used for that Drum Set’s 61-note range. Changing this parameter transposes all note settings in the Drum Set Edit Window.

- **Footswitch Closing**: Selects the MIDI note generated when a footswitch, plugged into the D4/DM5’s footswitch input, is pressed.

- **Footswitch Held**: Selects the MIDI note generated when a trigger is received at External Trigger Input 1 while the footswitch is held down.
SPECIAL MENU COMMANDS IN THE DRUM SET EDIT WINDOW

The following **Edit** menu commands are available when the Drum Set Edit Window is active:

- **Note Chase**: Enables a sound in the D4/DM5 to be selected for editing simply by striking the associated pad or other trigger device.
- **1 Oct** (small screens): Sets the display in the Drum Set Edit Window to one octave.
- **2 Oct** (large screens): Sets the display in the Drum Set Edit Window to two octaves.

The following **Load/Send** menu commands are available when a D4 Drum Set Bank or Drum Set Edit Window is active:

- **Store Drum Set in D4**: Stores an edited Drum Set in the D4, as opposed to remaining only in the unit’s edit buffer. This saves the trouble of having to send the entire Bank to the D4 simply to store a single edited Drum Set.
  - This command is disabled when **Load/Send>Has Old ROMs** is checked.
- **Has Old ROMs**: Compensates for problems caused by older D4 ROM versions. See [ROM Versions Earlier Than 1.02, pg. 1](#)
CH 4: EDITING TRIGGER SETUPS

To edit a Trigger Setup:

1. Open a Trigger Setup Bank.

![Trigger Setup Bank Window]

2. Click the Edit button to open the Trigger Setup Edit Window.

**TRIGGER SETUP EDIT WINDOW**

The Trigger Setup Edit Window is where triggering parameters are set for each of the D4/DM5’s 12 external trigger inputs. Although each of the 21 Drum Sets has its own set of trigger note assignments, the following Trigger Setup parameters are global and therefore affect all Drum Sets.

![Trigger Setup Edit Window]

1. **Gain**: Sets the amount of amplification applied to the trigger input.
2. **Velocity Curve**: Sets the sensitivity of a trigger input with any of eight velocity response curves.
3 **Cross-Talk**: A threshold parameter that enables a trigger input to avoid false triggering from a nearby pad or drum being struck.

4 **Noise Floor**: A threshold parameter that enables the D4/DM5 to avoid false triggering by distinguishing between genuine triggers and ambient noise.

5 **Decay**: Sets a delay time during which the D4/DM5 will not accept another trigger for that input.

6 **Set Select**: Auditions any of the D4/DM5’s 21 Drum Sets during Trigger Setup configuration. The D4/DM5 can hold only one Trigger Setup at a time, so this feature is provided to audition how well the Trigger Setup works with different Drum Sets.

☆ **NOTE**: Option-clicking on the Drum Set pop-up opens the Edit Window for that Drum Set, enabling editing of Trigger Notes or sound assignments.

7 **Destination**: Displays the sounds, assigned to the corresponding MIDI notes, for the selected Drum Set.

8 **Note**: Displays the MIDI notes, assigned to the external trigger inputs, for the selected Drum Set.

Destination and Note columns cannot be edited from the Trigger Setup Window. These edits must be made from the Drum Set Edit Window.
CH 5: EDITING PROGRAM TABLE AND SYSTEM INFO

To edit a Program Table:

1. Open a Program Table Bank.

![DM5: Prog Tbl](image)

Figure 13: Program Table Bank Window

2. Click the **Edit** button to open the Program Table Edit Window.

**PROGRAM TABLE EDIT WINDOW**

The Program Table Edit Window specifies which Drum Set is selected when receiving a particular MIDI program change number.

![Program Table Edit Window](image)

Figure 14: Program Table Edit Window

The left column shows the program numbers with their corresponding Drum Set (chosen from a pop-up menu) in the right column.
When the Program Table Edit Window is open, the following commands are available from the Edit menu:

- **0-127, 1-128, or A11-B88**: Sets the numbering scheme for how patches appear when published to Name Manager compatible applications—like Opcode’s Vision.

- **Sequential Assign**: Opens the following dialog which sequentially assigns Drum Sets to the indicated range of program change numbers.

```
For MIDI program numbers
0 to 127
assign patches sequentially, starting with
Set0 Standard Set

[Cancel] [Assign]
```

**EDITING SYSTEM INFORMATION**

To edit the System Information:


![DM5: System Info](image)

```
<table>
<thead>
<tr>
<th>Device ID</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMS System Info</td>
<td>Edit</td>
</tr>
<tr>
<td>0 (unnamed)</td>
<td></td>
</tr>
</tbody>
</table>
```

Figure 15: System Information Bank Window

2. Click **Edit** button to open the System Information Edit Window.
The System Information Edit Window defines global MIDI settings, configures the footswitch mode, and enables “note chase.”

![System Information Edit Window](image)

1. **Footswitch Mode**: Configures the external footswitch jack for “Hi Hat” triggers or program advance (“Advance”).

2. **Note Chase Enable**: Enables or disables Note Chase, which allows selection of a sound for editing by striking the appropriate trigger or by sending the assigned MIDI note to the D4/DM5.

3. **Channel**: Sets the D4/DM5’s MIDI channel. This parameter is only enabled when Omni is set to “Off.”

4. **Omni**: Enables or disables MIDI Omni mode, determining whether the D4/DM5 responds to MIDI data on all channels or only to the one set by Channel.

5. **Thru Enabled**: Configures the D4/DM5’s MIDI Out jack as a MIDI Thru jack. If this is inadvertently checked, MIDI feedback problems may occur.

6. **Programs Enabled**: Allows the D4/DM5 to respond to MIDI program changes, based on its Program Change Table. If this box is not checked, the unit will not respond to program changes.

7. **Controllers Enabled**: Enables reception of MIDI continuous controller messages, as described in the D4/DM5 manual.