Recent | Who | Artists | Firewire | USB | Gfx | Windows | Mac | MacOS9 | IBM/DOS | ATARI ST | Midi Interfaces | Sequencers | MPCs | Roland "MC" | Roland "S" | E-mu | Ensoniq | Akai "S" | Samplers | soft-Samplers | Synths | soft-Synths (VSTi) | Roland "JV" | Modules | Drums | Tape | Mixers | hardware Effects | soft Effects | Midi Controllers | iOS | android | sw Timeline | Hackintosh This site exists to archive historical + crucial information related to computer assisted music production and related technologies; with the hopes of becoming a community of creatives who might make a significant intellectual contribution towards enhancing the quality of music production of both our generation and the next;  thanks for being here, and thank you for contributing. remember the past,  appreciate the present, and plan 4 the FUTURE >>>

Author Topic: Why can't I run Cubase 5.1 on Windows 95? (sos article 2002)  (Read 5363 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Administrator
  • Posts: 8907
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Why can't I run Cubase 5.1 on Windows 95? (sos article 2002)
« on: August 18, 2014, 04:04:15 PM »

Why can't I run Cubase 5.1 on Windows 95?

I've recently upgraded my copy of Cubase VST 3.5 to version 5.1 and, after several attempts to install it, I keep getting a list of errors. Having tried several times to contact Steinberg's 'nonexsistant' tech support, nearly a month later I found a forum in Club Cubase that dealt with the exact problem. Apparently, despite what it says in the manuals and on all the advertising, Cubase VST 5.1 will not run under Windows 95. So despite paying for the software, I'll now have wait until I can afford to upgrade my OS before I can use it.

From listening to others, it seems that nobody ever gets any reply from Steinberg and, for a company with their reputation, this isn't very good. I can't reinstall version 3.7, as I had to send its dongle back, and the new one doesn't work with the old software -- so I'm stuck.

Andy Sayner

PC Specialist Martin Walker replies: I had a look at the installation manual of my Cubase 5.0 update, and it did mention Windows 95, along with Windows 98 and 2000, as minimum requirements. However, when I followed this up with Steinberg Germany, I found that the latest 5.1 packaging only mentions Windows 98, ME, and 2000. This is the first version that doesn't officially support Windows 95, apparently not because there is any Cubase code that stops it working on this platform, but because there have been user problems with audio/MIDI drivers that are out of Steinberg's hands.

I've often contacted Steinberg's Helpline (020 8970 1924 in the UK), and found the tech support staff to be extremely helpful. They told me that they will happily send you a version 5.0 CD-ROM if you wish, which should scrape by running on the final Win 95C version, or return your 3.7 dongle and give you a refund if you prefer to return your 5.1 dongle to them.

However, there's a larger issue here. Windows 95 is now seven years old, making it extremely long in the tooth for an operating system, and it ís hardly surprising that many music developers are withdrawing support for it. It's always sensible to wait for at least a few months after release before upgrading, so that the lemmings expose any remaining bugs and they can be dealt with by an update or Service Pack, and of course there's no point in upgrading for the sake of it if you're happy with the performance of your existing operating system.

However, there comes a point when ignoring progress leaves you in a tricky situation. The majority of musicians still seem to be running Windows 98SE, and while this was still available as an upgrade it would have been an ideal way for you to bring your PC rather more up to date three or four years after installing Windows 95. The subsequent Windows ME would have been a possible upgrade for you as well.

Sadly, retailers are now only stocking the latest Windows XP, and as I mentioned in my review, having Windows 95 doesn't qualify you to install XP as an upgrade. You can probably buy a full OEM version for a similar price if you order a small hardware item at the same time, but if your PC is more than five years old then it will probably require the minimum of a BIOS update, as well as some hardware upgrades, since XP realistically requires a minimum of a 400MHz Pentium processor or equivalent, plus 128MB of RAM.

For any musician to stay abreast of new software developments, periodic computer upgrades become almost inevitable. Although Cubase 5.0 did introduce various new MIDI features, the majority were audio ones, and if you intend to make use of these then you almost certainly face the prospect of some major hardware upgrades, or even a new PC.

Despite the stated minimum requirements, Steinberg's recommended minimum system for Cubase 5.0 is a Pentium III 266MHz and 128MB of RAM running Win 98 or 2000. However, it's a sad fact of life that the latest software is designed to run best with computers that are not more than a couple of years old, and although you may scrape by with an older one, performance may still be sluggish.

-- http://www.soundonsound.com/sos/may02/articles/qa0502.asp