Recent | Who | Artists | WIN/PC | IBM/DOS | Macintosh | ATARI ST | Firewire | USB | GFX | Roland "S" | E-mu | Ensoniq | Akai "S" |
Samplers |Synths | soft-Samplers | soft-Synths | Roland "JV" |Modules | Drums | Tape | Mixers | hardware Effects | soft Effects | Midi Interfaces |Sequencers | MPCs | Roland "MC"Software | Midi ControllersiOS | android | sw Timeline*** "all things are possible with God" Mark 10:27 ***

* Are you ready to say GoodBye to the 2010's and HELLO to the 2020s!!!??? *

Author Topic: Motu Performer 1.22 (1985/1986) *DOWNLOAD* requires MacOS 6.0.3- compact mac  (Read 3015 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisNova777

  • Administrator
  • Posts: 8374
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info

Offline chrisNova777

  • Administrator
  • Posts: 8374
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Re: Motu Performer 1.22 (1985/1986) (midi only) *DOWNLOAD*
« Reply #1 on: February 19, 2017, 05:58:57 AM »
does anyone know if this will work on mac os 7.6.1?
8.1+?
9.2?

any info at all is appreciated

Offline xenmaster0

  • Newbie
  • Posts: 4
Re: Motu Performer 1.22 (1985/1986) (midi only) *DOWNLOAD*
« Reply #2 on: April 29, 2017, 12:18:03 AM »
I have both this program (MOTU Professional Performer 1.22) and MOTU Professional Composer on 800K Mac floppies (also on my Mac Plus hard drive).
Alas, these programs will _not_ run on any Mac OS beyond 6.0.3 and will not run Macs with ROMs beyond the Mac SE30.  The SE30 had a 256K ROM, whereas the Quadra 650 had a 1 meg ROM.

The SE30 had a 'dirty' ROM with some legacy 24-bit code in it, and that's probably why Performer 1.X runs on the SE30 but not the Quadras.

Tried running MOTU performer on System 7.X/8.X/9.X on both my working Quadra 650 and my beige G3 266 rev 2 with 750 MB RAM and System 8.1/9.2.2. The ROMs on both those machines crash MOTU Performer 1.X hard. Pro Composer sort of kind of runs on System 7.X, but won't save to anything, since Pro Composer 1.X requires MOTU Performer 1.X to save to MIDI files.

The only real way to run this program is on a Mac Plus or a Mac SE30
Even a Powerbook 180 won't run it. Also, as mentioned, Performer was designed to work with Composer because the two interact. Composer reads Performer 1.X files and turns 'em into music notation, Composer also takes the notation you enter & generates Performer 1.X files which are then spat out as MIDI messages on an old MIDI interface hooked up to the Mac Plus/SE 30.

EZVision from the 1980s can read Performer 1.X files and put 'em out as MIDI too.
MOTU Professional Composer eventually turned into the standalone program Composer's Mosaic. Very unstable. Mosaic reads and writes MIDI files directly and turns 'em into notation/turns notation into MIDI files.
Hope that helps.

Offline chrisNova777

  • Administrator
  • Posts: 8374
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Re: Motu Performer 1.22 (1985/1986) (midi only) *DOWNLOAD*
« Reply #3 on: April 30, 2017, 07:08:41 PM »
xenmaster thanks for sharing that detailed insight into the discrepencies u stated above!

that will save alot of people alot of frustration ..
this info was posted for historical importance mostly.
using performer 5 or 6 for mac os will most likely work fine
on g3/g4 computers running os 7.6.1-os 9.22

if it runs on the SE/30
then it must run on the macintosh II platform aswell
http://www.everymac.com/systems/apple/mac_ii/specs/mac_ii.html
http://www.everymac.com/systems/apple/mac_ii/specs/mac_iix.html
http://www.everymac.com/systems/by_year/macs-released-in-1989.html

Offline chrisNova777

  • Administrator
  • Posts: 8374
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Re: Motu Performer 1.22 (1985/1986) (midi only) *DOWNLOAD*
« Reply #4 on: July 21, 2017, 11:12:16 AM »
so anyway
what we are really looking for then is a copy of performer that is from a bit later on.. like version 3 or 4
v1.xx is too old (original macintosh series)
and we need one that will run on mac II generation + beyond.. that would be performer 3.xx and performer 4.xx

i only have copies of v5.5 and v6.0

Offline chrisNova777

  • Administrator
  • Posts: 8374
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Re: Motu Performer 1.22 (1985/1986) (midi only) *DOWNLOAD*
« Reply #5 on: July 22, 2017, 03:51:53 PM »
yea i tried to run this performer 1.22 app earlier and it crashed my g4 i had to cold boot

its definately not going to be OMS compatible;
which is why it probably requires such an old macos version to run on, because of the underlying midi systems.. maybe it even predates midi manager? i think so? http://archive.cassiel.com/space/Gearhead/Apple+MIDI+Manager