*** "All things are possible" Mark 10:27 ***
please feel free to post relevant information in the pre-existing threads if file attachments or images are not displayed you may need to register/login logging in also enables you to use the arrow keys to page back + forth Recent | Who | Artists | USB | Firewire | VST | Retrospects | Commodore | ATARI ST | Amiga | IBM/DOS | WIN/PC | Mac | MacOS9 | Drums | Drum Machines | Synths | Modules | Samplers | Tape | Mixers | Software | GFX | Midi Interfaces | Midi Sequencers | ControllersE-mu | Ensoniq | Akai "S" | MPCs | Roland "MC"Roland "S" | Roland "JV" | JV addons | Hardware Effects | iOS | android | DAW Software Timeline

Author Topic: mac applications newly released during Leopard (Oct 2007 - Aug 2009)  (Read 10551 times)

0 Members and 1 Guest are viewing this topic.

Online chrisNova777

  • Underground tech support agent
  • Administrator
  • Posts: 7828
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
Mac OS 7 | Mac OS 8Mac Os 9 | Puma | Jaguar | Panther | Tiger | Leopard | Snow Leopard | Mtn Lion | windows

October 2007 - August 2009
Applications first released between the release of Leopard (Oct 2007) & the release of Snow Leopard (Aug 2009)
Ableton Live 7 (11/1/2007) (req panther+)
Reason 4.0 (11/1/2007) (req tiger+)
Logic pro 8 (11/7/2007) (req tiger+)
Nuendo 4 (12/1/2007) (req Tiger+)
Pro Tools M-powered 7.42 update (7/15/2008)
Digital Performer 6 (11/8/2008) (req tiger 10.4.7+)
Pro Tools LE 8 (req leopard+) (Pro Tools 8.0.5 last v. to work on leopard)
Pro Tools M-powered 8 (1/1/2009) (req leopard 10.5.5+)
Cubase 5 (3/9/2009) (req leopard+) (cubase 4 versions still compatible)[/b]
Ableton Live 8 (4/15/2009) (req tiger+)
Native Instruments Komplete 5 (7/1/2009)
Logic Pro 9 (7/9/2009) (req leopard 10.5.7+)

click to view the daw timeline
click to view the 'new world' mac g3/g4 timeline




« Last Edit: May 20, 2019, 07:00:39 PM by chrisNova777 »

Online chrisNova777

  • Underground tech support agent
  • Administrator
  • Posts: 7828
  • Gender: Male
  • "Vintage MIDI Sequencing + Audio Production"
    • www.oldschooldaw.com | vintage audio production software + hardware info
https://imgur.com/gallery/6gfKdaL
if using leopard 10.5.x on intel cpu you are going to need a copy of Firefox 3.6
https://ftp.mozilla.org/pub/firefox/releases/3.6rc2/mac/en-US/Firefox%203.6%20RC%202.dmg

i was told v21 is usable but it didnt work for me on 10.5.7
https://ftp.mozilla.org/pub/firefox/releases/21.0/mac/en-US/
« Last Edit: May 18, 2019, 08:01:16 PM by chrisNova777 »